summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/openvdb/openvdb-5.2.0-r1.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild63
1 files changed, 43 insertions, 20 deletions
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
index 2f2eb78d9fcb..a176389a2a05 100644
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
@@ -1,29 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils flag-o-matic python-single-r1
+inherit cmake flag-o-matic python-single-r1
-DESCRIPTION="Libs for the efficient manipulation of volumetric data"
+DESCRIPTION="Library for the efficient manipulation of volumetric data"
HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/dreamworksanimation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+abi4-compat doc python test"
+IUSE="abi3-compat abi4-compat +abi5-compat doc python test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ ^^ ( abi3-compat abi4-compat abi5-compat )
+"
RDEPEND="
- >=dev-libs/boost-1.62:=
- >=dev-libs/c-blosc-1.5.0
- dev-libs/jemalloc
- dev-libs/log4cplus
- media-libs/glfw:=
+ dev-libs/boost:=
+ dev-libs/c-blosc:=
+ dev-libs/jemalloc:=
+ dev-libs/log4cplus:=
+ media-libs/glfw
media-libs/openexr:=
sys-libs/zlib:=
x11-libs/libXcursor
@@ -33,13 +36,18 @@ RDEPEND="
python? (
${PYTHON_DEPS}
$(python_gen_cond_dep '
- >=dev-libs/boost-1.62:=[python,${PYTHON_MULTI_USEDEP}]
- dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ dev-libs/boost:=[python?,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
')
- )"
+ )
+"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
dev-cpp/tbb
+"
+
+BDEPEND="
virtual/pkgconfig
doc? (
app-doc/doxygen
@@ -49,10 +57,14 @@ DEPEND="${RDEPEND}
dev-texlive/texlive-latex
dev-texlive/texlive-latexextra
)
- test? ( dev-util/cppunit )"
+ test? ( dev-util/cppunit )
+"
-PATCHES=( "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
+PATCHES=(
+ "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
"${FILESDIR}/${P}-use-pkgconfig-for-ilmbase-and-openexr.patch"
+ "${FILESDIR}/${PN}-4.0.2-fix-const-correctness-for-unittest.patch"
+ "${FILESDIR}/${PN}-4.0.2-fix-build-docs.patch"
)
pkg_setup() {
@@ -62,11 +74,22 @@ pkg_setup() {
src_configure() {
local myprefix="${EPREFIX}/usr/"
+ local version
+ if use abi3-compat; then
+ version=3
+ elif use abi4-compat; then
+ version=4
+ elif use abi5-compat; then
+ version=5
+ else
+ die "Openvdb ABI version not specified"
+ fi
+
local mycmakeargs=(
-DBLOSC_LOCATION="${myprefix}"
-DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-DGLFW3_LOCATION="${myprefix}"
- -DOPENVDB_ABI_VERSION_NUMBER=$(usex abi4-compat 4 5)
+ -DOPENVDB_ABI_VERSION_NUMBER="${version}"
-DOPENVDB_BUILD_DOCS=$(usex doc)
-DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
-DOPENVDB_BUILD_UNITTESTS=$(usex test)
@@ -78,5 +101,5 @@ src_configure() {
use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
- cmake-utils_src_configure
+ cmake_src_configure
}