summaryrefslogtreecommitdiff
path: root/media-gfx/graphite2/graphite2-1.3.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphite2/graphite2-1.3.14.ebuild')
-rw-r--r--media-gfx/graphite2/graphite2-1.3.14.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/media-gfx/graphite2/graphite2-1.3.14.ebuild b/media-gfx/graphite2/graphite2-1.3.14.ebuild
index 7293cfb0a10e..3f1a3d4d8c22 100644
--- a/media-gfx/graphite2/graphite2-1.3.14.ebuild
+++ b/media-gfx/graphite2/graphite2-1.3.14.ebuild
@@ -3,10 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-
CMAKE_ECLASS=cmake
GENTOO_DEPEND_ON_PERL="no"
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit perl-module python-any-r1 cmake-multilib
DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
@@ -19,17 +18,19 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x
IUSE="perl test"
RESTRICT="!test? ( test )"
-RDEPEND="
- perl? ( dev-lang/perl:= )
+RDEPEND="perl? ( dev-lang/perl:= )"
+DEPEND="
+ perl? ( dev-lang/perl )
+ test? ( dev-libs/glib:2 )
"
-DEPEND="${RDEPEND}
+BDEPEND="
perl? (
+ dev-lang/perl
dev-perl/Locale-Maketext-Lexicon
dev-perl/Module-Build
)
test? (
${PYTHON_DEPS}
- dev-libs/glib:2
$(python_gen_any_dep 'dev-python/fonttools[${PYTHON_USEDEP}]')
media-libs/fontconfig
perl? ( virtual/perl-Test-Simple )