summaryrefslogtreecommitdiff
path: root/media-gfx/gifsicle
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/gifsicle')
-rw-r--r--media-gfx/gifsicle/Manifest2
-rw-r--r--media-gfx/gifsicle/gifsicle-1.92.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/media-gfx/gifsicle/Manifest b/media-gfx/gifsicle/Manifest
index e07bb68e52f3..4943fa76dec4 100644
--- a/media-gfx/gifsicle/Manifest
+++ b/media-gfx/gifsicle/Manifest
@@ -1,3 +1,5 @@
DIST gifsicle-1.91.tar.gz 571588 BLAKE2B be3973141e57618d50efb5205f79e485a4450ceed02d6c718e49305250941656f0d220c91d2056554348d14348ed1ddf03f0aa9c47e22589994c5e80046422f6 SHA512 49b89e6f99bffd0dd732c920b936c2430a2f4f595d46e41654e5f39f180acaf9b0a4aec6cf52597c470d7c60265f16b730f6ce82e08701a2054fc3d08754c6da
+DIST gifsicle-1.92.tar.gz 575199 BLAKE2B 53716621846b14c0727e05893cb1876572ab80aa4d444c2b75499b541a19a5e45738b817c203b3926301378b2211a3263311c424cd8dd53e71d2b60f28ecdfb3 SHA512 5d9539eb5a6a8b87aed49ff3ca3d62e337845edbd05459b002369d571f74878c99740c34f50b4c86e5b8787ff189d4c21230e4f9019cd96a09db603afd7563dc
EBUILD gifsicle-1.91.ebuild 664 BLAKE2B 68b81b9e33c05331fa0b57886797b3f5a7629b9736889604c1d284628719bcfec5b446ae43eb2711145ed107681c20896d18d58d2caa5a6a1e39ccab65da0619 SHA512 378e4bb6251fe7ffed3263229aa20a6c4f0d2c3be6154049f91c9535b27f5e0c105b31c82c28870941921c2c42da6d104bf5a877ab36f706b45a3cb463748f8c
+EBUILD gifsicle-1.92.ebuild 664 BLAKE2B c2bb30c984b892252b5c0f6b88197ac976d90d94e9c20075630e4c793e74ff731218e4ac5c819765c6fc61390bc00d44d8294933d2fd2b36f9ab56e2a9ffc8b7 SHA512 5584aa0b1d3cbe06fc693709f8e600b34dddde0cb3febf4a35ebb76cdcdff4be4e76cdace85b47b94fefe7793a0a9d0cfcdc1e629d2c1d1b104dfdc77fca1a8d
MISC metadata.xml 255 BLAKE2B f12a1ca502ad96bd6de4c8b83dfb8887ab70dec78f10a8b52dcd4618eb182192477ddca18738d734a43f3c7ac3b5e0955f4ae9347ea80e788a92974c7d50a574 SHA512 b7bc93530a1726c2d4dfbc71ae29cfbb57712fd9fdd2e76fd52f35ab4368cba0497b50145d1527a3b79e465d459a380821bb1371a01c2e915dc9adc6c7fafd5f
diff --git a/media-gfx/gifsicle/gifsicle-1.92.ebuild b/media-gfx/gifsicle/gifsicle-1.92.ebuild
new file mode 100644
index 000000000000..a51d01b08353
--- /dev/null
+++ b/media-gfx/gifsicle/gifsicle-1.92.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Create, manipulate, and optimize GIF images and animations"
+HOMEPAGE="https://www.lcdf.org/~eddietwo/gifsicle/ https://github.com/kohler/gifsicle"
+SRC_URI="https://www.lcdf.org/~eddietwo/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="X"
+
+RDEPEND="
+ X? (
+ x11-libs/libX11
+ x11-libs/libXt
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ X? ( x11-base/xorg-proto )
+"
+DOCS=(
+ NEWS.md
+ README.md
+)
+
+src_configure() {
+ econf $(usex X "" "--disable-gifview")
+}