summaryrefslogtreecommitdiff
path: root/media-gfx/freewrl
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/freewrl')
-rw-r--r--media-gfx/freewrl/Manifest4
-rw-r--r--media-gfx/freewrl/freewrl-3.0.0-r1.ebuild16
-rw-r--r--media-gfx/freewrl/freewrl-9999.ebuild15
3 files changed, 17 insertions, 18 deletions
diff --git a/media-gfx/freewrl/Manifest b/media-gfx/freewrl/Manifest
index 3ce13ff752fc..1563e850ae2f 100644
--- a/media-gfx/freewrl/Manifest
+++ b/media-gfx/freewrl/Manifest
@@ -1,5 +1,5 @@
AUX freewrl-3.0.0-fno-common.patch 223 BLAKE2B 007d3fcb08acc5da859d28564e54558394a3f5fd23c1662e9d39e3c6d50c03cc5b024f7e4b72cdd6000249a67250a5c70e070c85d7e4f26e312e97a0895df54b SHA512 538bb6a1afdf7103e6ecc01dbd7005e33c14c01437f9c3666e1749bba8612c7cdb998bb4fb4e8d9e22663be97dfa991ac68a3e269c0817d71df8da54a5e417af
DIST freewrl-3.0.0.tar.bz2 1567282 BLAKE2B 84bf924ce51d70aca0baa504dba0726af82b3d2ff93de87bd18ab772f6bdbcc50807a496c14264006894b6c52bfe9844e672412162f3df1107453fa1f8b066a3 SHA512 12e75c6891238fbc9c750a9449c8a6a9f4b86124ac12871adbfb3c68b7ef09f35d3709dcb63693e50f8ac824170aef3b97854a72de0b324e67fbbb7c081675a0
-EBUILD freewrl-3.0.0-r1.ebuild 4460 BLAKE2B 3128a4878d9de0684195cf958a55e3bc4ce5b4ca09268953fd798daeb65557b0face9703e005b39ed82ae47cb47058cc9429a6dac356ad97f2be5a71e33e62b0 SHA512 b46d091ddc13e80d13a47c96bbf7c9658582da825c3b2e1912abe8618167158b2d205257e05bfbb76ecee700220824440d15cc1016cab62e4f9c45b779ca3964
-EBUILD freewrl-9999.ebuild 4475 BLAKE2B cb6bb434408a491065a616020bc46940496996a2f3087eb7f035dab0b783024f408c4f314441b6ece02e9d957f0e51e565331597983fac527358e2851da9516d SHA512 f2fecd0bcb9f98a3ff3ed774ab6bd75be3e24f3cdf3dfe89ae4ac17e690425c97612f16cb91394cfb17f95195e387c7cade1600680c5d1b2b9b76a65a600c1c5
+EBUILD freewrl-3.0.0-r1.ebuild 4476 BLAKE2B 80bd01f1a801d177fb4db154611037dc51e05809ae47d139936dbc74f9f53a60a5d5f56704a2222df8ac71b9621113bf1e1bfe7f4b2bea6555217d99032a6275 SHA512 3dab57e3c992fffbb27a70f87ff762330077579952e7d3dd36a2b1db56405213c8423013ea8f4054e5588208c449213f547488349f16335d16b100c188885fd3
+EBUILD freewrl-9999.ebuild 4490 BLAKE2B a3d0c2830ef600d27162fc568dfe54a41c708e6675e5ad9387c884d7f83fb615b7c19b4e7ece397558b000a1fd8e7333ec44f576f6a664db3564c6d9d65beb3a SHA512 1c7ba90270113d7ba20b5e1f919bd008d5a1da91158cee7d3667238c288090d02ff274a68d0aa2691ca7439914cd09c336d807c932cff5b687c9d0ab9dcf74a4
MISC metadata.xml 1302 BLAKE2B eb8522dbaadd9c9ebc8d3b5e03072fc7b57f6d87046f52104985a5e0e8f40669b53906921286d1d2c79e393853cac4c88f5a351c7bd0c38e3b9905308c0a890e SHA512 f7581007975722b3d16cf349c55ab67b5cf92a47316399adefb38a9413669f544c9fa5cc922f02f5a7473d4570d884d561dc8ef397347eca80494964f2f4faf0
diff --git a/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild b/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
index b7a8547435d6..545457a35528 100644
--- a/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
+++ b/media-gfx/freewrl/freewrl-3.0.0-r1.ebuild
@@ -3,13 +3,12 @@
EAPI=5
-inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
+inherit autotools nsplugins epatch java-pkg-opt-2 multilib toolchain-funcs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="git://git.code.sf.net/p/freewrl/git"
S="${WORKDIR}/${P}/freex3d"
- SRC_URI=
else
SRC_URI="mirror://sourceforge/freewrl/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
@@ -17,6 +16,7 @@ fi
DESCRIPTION="VRML97 and X3D compliant browser, library, and web-browser plugin"
HOMEPAGE="http://freewrl.sourceforge.net/"
+
LICENSE="GPL-3"
SLOT="0"
IUSE="curl debug java libeai motif +nsplugin opencl osc +sox static-libs"
@@ -85,8 +85,8 @@ src_configure() {
JAVASCRIPT_ENGINE_LIBS="-ljs"
fi
if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
- JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
- JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $($(tc-getPKG_CONFIG) --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$($(tc-getPKG_CONFIG) --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
fi
export JAVASCRIPT_ENGINE_CFLAGS
export JAVASCRIPT_ENGINE_LIBS
@@ -135,9 +135,9 @@ src_install() {
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
- elog "path. If you do not have firefox installed or you wish to use a different"
- elog "web browser to open links that are within VRML / X3D files, please be sure to"
- elog "specify the command via your BROWSER environment variable."
+ elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
+ elog "path. If you do not have firefox installed or you wish to use a different"
+ elog "web browser to open links that are within VRML / X3D files, please be sure to"
+ elog "specify the command via your BROWSER environment variable."
fi
}
diff --git a/media-gfx/freewrl/freewrl-9999.ebuild b/media-gfx/freewrl/freewrl-9999.ebuild
index 0f77fc735ce4..3e3d9594c1e4 100644
--- a/media-gfx/freewrl/freewrl-9999.ebuild
+++ b/media-gfx/freewrl/freewrl-9999.ebuild
@@ -3,14 +3,13 @@
EAPI=5
-inherit autotools nsplugins eutils flag-o-matic java-pkg-opt-2 multilib
+inherit autotools nsplugins epatch java-pkg-opt-2 multilib toolchain-funcs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.code.sf.net/p/freewrl/git"
EGIT_BRANCH="develop"
S="${WORKDIR}/${P}/freex3d"
- SRC_URI=
else
SRC_URI="mirror://sourceforge/freewrl/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
@@ -86,8 +85,8 @@ src_configure() {
JAVASCRIPT_ENGINE_LIBS="-ljs"
fi
if has_version "dev-lang/spidermonkey:0[threadsafe]" ; then
- JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $(pkg-config --cflags nspr)"
- JAVASCRIPT_ENGINE_LIBS="$(pkg-config --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
+ JAVASCRIPT_ENGINE_CFLAGS+=" -DJS_THREADSAFE $($(tc-getPKG_CONFIG) --cflags nspr)"
+ JAVASCRIPT_ENGINE_LIBS="$($(tc-getPKG_CONFIG) --libs nspr) ${JAVASCRIPT_ENGINE_LIBS}"
fi
export JAVASCRIPT_ENGINE_CFLAGS
export JAVASCRIPT_ENGINE_LIBS
@@ -137,9 +136,9 @@ src_install() {
pkg_postinst() {
if [[ -z ${REPLACING_VERSIONS} ]]; then
- elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
- elog "path. If you do not have firefox installed or you wish to use a different"
- elog "web browser to open links that are within VRML / X3D files, please be sure to"
- elog "specify the command via your BROWSER environment variable."
+ elog "By default, FreeWRL expects to find the 'firefox' binary in your include"
+ elog "path. If you do not have firefox installed or you wish to use a different"
+ elog "web browser to open links that are within VRML / X3D files, please be sure to"
+ elog "specify the command via your BROWSER environment variable."
fi
}