summaryrefslogtreecommitdiff
path: root/media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild')
-rw-r--r--media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild b/media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..dd27037aa323
--- /dev/null
+++ b/media-gfx/fdm-materials/fdm-materials-4.6.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_PN="fdm_materials"
+
+DESCRIPTION="FDM materials for media-gfx/cura"
+HOMEPAGE="https://github.com/Ultimaker/fdm_materials"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="embedded"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DEMBEDDED=$(usex embedded on off)
+ )
+ cmake_src_configure
+}