summaryrefslogtreecommitdiff
path: root/media-gfx/argyllcms
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/argyllcms')
-rw-r--r--media-gfx/argyllcms/Manifest2
-rw-r--r--media-gfx/argyllcms/argyllcms-2.1.2.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/argyllcms/Manifest b/media-gfx/argyllcms/Manifest
index 1d4f033e508e..375fdc2db55c 100644
--- a/media-gfx/argyllcms/Manifest
+++ b/media-gfx/argyllcms/Manifest
@@ -1,4 +1,6 @@
DIST Argyll_V2.1.1_src.zip 13825860 BLAKE2B c1a748cf8ecd8e04164b0281e5cfb708386b196ea75bef6be02945d1a0cd1d191d069420628612ce0bd24028e40221a988becc3eba16293555376d20ab3a4bf5 SHA512 551b90c245d15e401c96c76ec0be66053bd75ca4d8b668a41841d72197820ed27d4d0186f903c126f7bacd667170e8e45e42ad31fcd44ec3276558b87b520565
+DIST Argyll_V2.1.2_src.zip 13837053 BLAKE2B 2ad4352c79073a597ff664df8be258d56b048e1d24f677790824145f47a0b52213d219e781f8b2157f396b5a6a1d2e089d357a35ab1b8d9f58885a342f265024 SHA512 cd986db52003d12f7fc6d795cc0471d0f6a3f612f8f8c799f2824cbbd4d0ff27d215d3825222b7f2664e8f7cd3413ad46c361765c327dd5cf9f3827111155bdd
EBUILD argyllcms-2.1.1-r1.ebuild 2113 BLAKE2B 7491a7a5fccb9ca0675dced451e2d8c88b804f279e19eb53c0e6afe8a64c415ae0d9b954428f490d1050e86ff01ad8ff74bbc133b6a189951336c65a6c44cbb3 SHA512 f4180c02dcc2997607ffea5e174626609809a08346b6c65c7f51cb79c2e57eff5de83909855a35712b9d5f055d2ece7cfdafc6af2b9ed0c63ab9570f3cd7bd44
EBUILD argyllcms-2.1.1.ebuild 2049 BLAKE2B 366bead11308fb50f97eb8a443eee23677463e8b249300b3544ea9157fbcf19e603fd1bd506c14e3470965717d84916a1456a70282b68b2b970c1885cbae1193 SHA512 a1b1a16d0f1bd9a8ccfa149de5978aeddc5c189a28869c3836dd35c009d016f8dedbf292b6fc73702869e265635a82cf3e44599333130f60ceeb16be23852f1c
+EBUILD argyllcms-2.1.2.ebuild 2113 BLAKE2B de2d523c185232f290c00d821ea682c91d9a777315b5455f4f5f8c5d0518c6aefb85ca07bf8d5c50ad1ca34314e6b6fb2643e947c1c5d7ffe3d0bdb8e6320eaa SHA512 5c93e069641cb39aa89cba96a51a89b03d04622e37ca88586a2df6de5fe2071c493f288f6e315162a28c21d68b37864615d758812fb1767a8494776874b3ee89
MISC metadata.xml 252 BLAKE2B f7125c07f7cb9fe1a8d301f198091320ba83ef3547e579b9825298715066ba3506be216900b5317106da011f95df9411b99b100f14f741832ab500fda6acb788 SHA512 6a56c24e3731dd9512fa264d3dce1fe36ace891a17394c483586e0be1fffd153e901228d3ee9c471a226b04cec27d3f78ed2de491e46238de4b06538dab7e724
diff --git a/media-gfx/argyllcms/argyllcms-2.1.2.ebuild b/media-gfx/argyllcms/argyllcms-2.1.2.ebuild
new file mode 100644
index 000000000000..8f67157add6b
--- /dev/null
+++ b/media-gfx/argyllcms/argyllcms-2.1.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic multiprocessing toolchain-funcs udev
+
+MY_P="Argyll_V${PV}"
+
+DESCRIPTION="Open source, ICC compatible color management system"
+HOMEPAGE="http://www.argyllcms.com/"
+SRC_URI="http://www.argyllcms.com/${MY_P}_src.zip"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="doc libressl"
+
+RDEPEND="
+ media-libs/tiff:0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ x11-libs/libXScrnSaver
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-util/ftjam"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ # Make it respect LDFLAGS
+ echo "LINKFLAGS += ${LDFLAGS} ;" >> Jamtop
+
+ # Evil hack to get --as-needed working. The build system unfortunately lists all
+ # the shared libraries by default on the command line _before_ the object to be built...
+ echo "STDLIBS += -ldl -lrt -lX11 -lXext -lXxf86vm -lXinerama -lXrandr -lXau -lXdmcp -lXss -ltiff -ljpeg ;" >> Jamtop
+
+ append-cflags -DUNIX -D_THREAD_SAFE
+
+ sed \
+ -e 's:CCFLAGS:CFLAGS:g' \
+ -e "s:ar rusc:$(tc-getAR) rusc:g" \
+ -i Jambase || die
+
+ tc-export CC RANLIB
+
+ jam -dx -fJambase "-j$(makeopts_jobs)" || die
+}
+
+src_install() {
+ jam -dx -fJambase install || die
+
+ rm bin/License.txt || die
+
+ pushd bin > /dev/null
+ local binname
+ for binname in * ; do
+ newbin ${binname} argyll-${binname}
+ done
+ popd > /dev/null
+
+ dodoc log.txt Readme.txt ttbd.txt notes.txt
+ if use doc; then
+ docinto html
+ dodoc doc/*html doc/*jpg doc/*gif
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r ref
+
+ udev_dorules usb/55-Argyll.rules
+}
+
+pkg_postinst() {
+ elog "If you have a Spyder2 you need to extract the firmware"
+ elog "from the CVSpyder.dll of the windows driver package"
+ elog "and store it as /usr/share/color/spyd2PLD.bin"
+ echo
+ elog "For further info on setting up instrument access read"
+ elog "http://www.argyllcms.com/doc/Installing_Linux.html"
+ echo
+}