summaryrefslogtreecommitdiff
path: root/media-fonts/spleen/spleen-2.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-fonts/spleen/spleen-2.0.2.ebuild')
-rw-r--r--media-fonts/spleen/spleen-2.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/media-fonts/spleen/spleen-2.0.2.ebuild b/media-fonts/spleen/spleen-2.0.2.ebuild
new file mode 100644
index 000000000000..de0696bfbeb9
--- /dev/null
+++ b/media-fonts/spleen/spleen-2.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit font
+
+DESCRIPTION="Monospaced bitmap fonts for consoles and terminals"
+HOMEPAGE="https://www.cambus.net/spleen-monospaced-bitmap-fonts/
+ https://github.com/fcambus/spleen/"
+SRC_URI="https://github.com/fcambus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( AUTHORS ChangeLog README.md )
+FONT_SUFFIX="otf pcf.gz psfu.gz"
+
+src_compile() {
+ gzip -n9 *.pcf *.psfu || die
+}