summaryrefslogtreecommitdiff
path: root/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild')
-rw-r--r--mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
index d6a7c0848c40..5634e8c0117e 100644
--- a/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
+++ b/mate-extra/mate-system-monitor/mate-system-monitor-1.24.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit mate
+inherit mate toolchain-funcs
if [[ ${PV} != 9999 ]]; then
KEYWORDS="amd64 ~arm ~arm64 x86"
@@ -51,9 +51,10 @@ src_configure() {
if use elogind || use systemd; then
myconf+=( --enable-systemd )
if use elogind; then
+ local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
- SYSTEMD_CFLAGS=`pkg-config --cflags "libelogind" 2>/dev/null`
- SYSTEMD_LIBS=`pkg-config --libs "libelogind" 2>/dev/null`
+ SYSTEMD_CFLAGS="$(${pkgconfig} --cflags "libelogind")"
+ SYSTEMD_LIBS="$(${pkgconfig} --libs "libelogind")"
)
fi
else