summaryrefslogtreecommitdiff
path: root/mail-mta/esmtp/esmtp-1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-mta/esmtp/esmtp-1.2.ebuild')
-rw-r--r--mail-mta/esmtp/esmtp-1.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/mail-mta/esmtp/esmtp-1.2.ebuild b/mail-mta/esmtp/esmtp-1.2.ebuild
new file mode 100644
index 000000000000..e512a546b22b
--- /dev/null
+++ b/mail-mta/esmtp/esmtp-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="esmtp is a user configurable relay-only Mail Transfer Agent (MTA) with a sendmail compatible syntax"
+HOMEPAGE="http://esmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="net-libs/libesmtp
+ dev-libs/openssl
+ sys-devel/flex"
+RDEPEND="net-libs/libesmtp
+ dev-libs/openssl
+ !mail-mta/courier
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp
+ !mail-mta/opensmtpd"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO sample.esmtprc || die
+}
+
+pkg_postinst() {
+ elog "A sample esmtprc file has been installed in /usr/share/doc/${P}"
+}