summaryrefslogtreecommitdiff
path: root/mail-filter/opendmarc/opendmarc-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-filter/opendmarc/opendmarc-1.3.3.ebuild')
-rw-r--r--mail-filter/opendmarc/opendmarc-1.3.3.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/mail-filter/opendmarc/opendmarc-1.3.3.ebuild b/mail-filter/opendmarc/opendmarc-1.3.3.ebuild
deleted file mode 100644
index c8ebaefc31dc..000000000000
--- a/mail-filter/opendmarc/opendmarc-1.3.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools user multilib systemd
-
-DESCRIPTION="Open source DMARC implementation"
-HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
-SRC_URI="https://github.com/trusteddomainproject/OpenDMARC/archive/rel-${PN}-${PV//./-}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="spf +reports static-libs"
-
-DEPEND="reports? ( dev-perl/DBI )
- || ( mail-filter/libmilter mail-mta/sendmail )"
-RDEPEND="${DEPEND}
- reports? (
- dev-perl/DBD-mysql
- dev-perl/HTTP-Message
- dev-perl/Switch
- )
- spf? ( mail-filter/libspf2 )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.3.2-multiple-From.patch
- "${FILESDIR}"/${PN}-1.3.3-CVE-2020-12460.patch
-)
-
-S=${WORKDIR}/OpenDMARC-rel-${PN}-${PV//./-}
-
-pkg_setup() {
- enewgroup milter
- enewuser milter -1 -1 /var/lib/milter milter
-}
-
-src_prepare() {
- default
-
- # fix issue after they removed docs
- sed -i -e '/^\s\+docs\/Makefile/d' configure.ac || die
-
- eautoreconf
- if use !reports ; then
- sed -i -e '/^SUBDIRS =/s/reports//' Makefile.in || die
- fi
-}
-
-src_configure() {
- econf \
- $(use_with spf) \
- $(use_with spf spf2-include "${EPREFIX}"/usr/include/spf2) \
- $(use_with spf spf2-lib "${EPREFIX}"/usr/$(get_libdir)) \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.la
-
- newinitd "${FILESDIR}"/opendmarc.initd opendmarc
- newconfd "${FILESDIR}"/opendmarc.confd opendmarc
- systemd_dounit "${FILESDIR}/${PN}.service"
-
- dodir /etc/opendmarc
-
- # create config file
- sed \
- -e 's:^# UserID .*$:UserID milter:' \
- -e "s:^# PidFile .*:PidFile ${EPREFIX}/var/run/opendmarc/opendmarc.pid:" \
- -e '/^# Socket /s:^# ::' \
- "${S}"/opendmarc/opendmarc.conf.sample \
- > "${ED}"/etc/opendmarc/opendmarc.conf \
- || die
-}