summaryrefslogtreecommitdiff
path: root/mail-client/neomutt/neomutt-99999999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/neomutt/neomutt-99999999.ebuild')
-rw-r--r--mail-client/neomutt/neomutt-99999999.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/mail-client/neomutt/neomutt-99999999.ebuild b/mail-client/neomutt/neomutt-99999999.ebuild
index aec8ac349253..74180642cbc4 100644
--- a/mail-client/neomutt/neomutt-99999999.ebuild
+++ b/mail-client/neomutt/neomutt-99999999.ebuild
@@ -21,9 +21,11 @@ HOMEPAGE="https://neomutt.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
+IUSE="autocrypt berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
ssl tokyocabinet test"
+REQUIRED_USE="
+ autocrypt? ( gpgme )"
CDEPEND="
app-misc/mime-types
@@ -43,6 +45,7 @@ CDEPEND="
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17:= )
gpgme? ( >=app-crypt/gpgme-1.13.1:= )
+ autocrypt? ( >=dev-db/sqlite-3 )
idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
notmuch? ( net-mail/notmuch:= )
@@ -80,6 +83,7 @@ src_configure() {
"$(use_enable nls)"
"$(use_enable notmuch)"
+ "$(use_enable autocrypt)"
"$(use_enable gpgme)"
"$(use_enable pgp-classic pgp)"
"$(use_enable smime-classic smime)"
@@ -145,4 +149,9 @@ pkg_postinst() {
ewarn " and smime-classic (old smime) from your USE-flags and"
ewarn " only enable gpgme."
fi
+
+ if use autocrypt && ! use idn; then
+ ewarn " It is highly recommended that NeoMutt be also configured"
+ ewarn " with idn when autocrypt is enabled."
+ fi
}