summaryrefslogtreecommitdiff
path: root/mail-client/neomutt/neomutt-20201127.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/neomutt/neomutt-20201127.ebuild')
-rw-r--r--mail-client/neomutt/neomutt-20201127.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail-client/neomutt/neomutt-20201127.ebuild b/mail-client/neomutt/neomutt-20201127.ebuild
index 2fbecf8b7800..4a1c914f9bb0 100644
--- a/mail-client/neomutt/neomutt-20201127.ebuild
+++ b/mail-client/neomutt/neomutt-20201127.ebuild
@@ -21,9 +21,11 @@ HOMEPAGE="https://neomutt.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
+IUSE="autocrypt berkdb doc gdbm gnutls gpgme idn kerberos kyotocabinet libressl
lmdb nls notmuch pgp-classic qdbm sasl selinux slang smime-classic
ssl tokyocabinet test"
+REQUIRED_USE="
+ autocrypt? ( gpgme )"
CDEPEND="
app-misc/mime-types
@@ -42,7 +44,8 @@ CDEPEND="
qdbm? ( dev-db/qdbm )
tokyocabinet? ( dev-db/tokyocabinet )
gnutls? ( >=net-libs/gnutls-1.0.17:= )
- gpgme? ( >=app-crypt/gpgme-0.9.0:= )
+ gpgme? ( >=app-crypt/gpgme-1.8.0:= )
+ autocrypt? ( >=dev-db/sqlite-3 )
idn? ( net-dns/libidn:= )
kerberos? ( virtual/krb5 )
notmuch? ( net-mail/notmuch:= )
@@ -80,6 +83,7 @@ src_configure() {
"$(use_enable nls)"
"$(use_enable notmuch)"
+ "$(use_enable autocrypt)"
"$(use_enable gpgme)"
"$(use_enable pgp-classic pgp)"
"$(use_enable smime-classic smime)"
@@ -145,4 +149,9 @@ pkg_postinst() {
ewarn " and smime-classic (old smime) from your USE-flags and"
ewarn " only enable gpgme."
fi
+
+ if use autocrypt && ! use idn; then
+ ewarn " It is highly recommended that NeoMutt be also configured"
+ ewarn " with idn when autocrypt is enabled."
+ fi
}