summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild
deleted file mode 100644
index 3fb8c16f75be..000000000000
--- a/lxqt-base/lxqt-runner/lxqt-runner-1.2.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="LXQt quick launcher"
-HOMEPAGE="https://lxqt-project.org/"
-
-MY_PV="$(ver_cut 1-2)"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-fi
-
-LICENSE="LGPL-2.1 LGPL-2.1+"
-SLOT="0"
-
-BDEPEND="
- >=dev-qt/linguist-tools-5.15:5
- >=dev-util/lxqt-build-tools-0.12.0
- virtual/pkgconfig
-"
-DEPEND="
- >=dev-cpp/muParser-2.2.3
- >=dev-libs/libqtxdg-3.10.0
- >=dev-qt/qtcore-5.15:5
- >=dev-qt/qtgui-5.15:5
- >=dev-qt/qtwidgets-5.15:5
- >=dev-qt/qtxml-5.15:5
- kde-frameworks/kwindowsystem:5
- =lxqt-base/liblxqt-${MY_PV}*:=
- =lxqt-base/lxqt-globalkeys-${MY_PV}*
-"
-RDEPEND="${DEPEND}"
-
-src_install() {
- cmake_src_install
- doman man/*.1
-}