summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild')
-rw-r--r--lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild
new file mode 100644
index 000000000000..5e610f95620c
--- /dev/null
+++ b/lxqt-base/lxqt-openssh-askpass/lxqt-openssh-askpass-0.17.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt OpenSSH user password prompt tool"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ =lxqt-base/liblxqt-$(ver_cut 1-2)*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+
+ newenvd - 99${PN} <<- _EOF_
+ SSH_ASKPASS='${EPREFIX}/usr/bin/lxqt-openssh-askpass'
+ _EOF_
+}