summaryrefslogtreecommitdiff
path: root/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild')
-rw-r--r--lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild b/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild
deleted file mode 100644
index 045498386add..000000000000
--- a/lxqt-base/lxqt-config/lxqt-config-0.13.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils eapi7-ver
-
-DESCRIPTION="LXQt system configuration control center"
-HOMEPAGE="https://lxqt.org/"
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
-else
- SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-LICENSE="GPL-2 GPL-2+ GPL-3 LGPL-2 LGPL-2+ LGPL-2.1+ WTFPL-2"
-SLOT="0"
-IUSE="+monitor"
-
-RDEPEND="
- >=dev-libs/libqtxdg-3.0.0
- dev-qt/qtcore:5
- dev-qt/qtdbus:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- dev-qt/qtxml:5
- kde-frameworks/kwindowsystem:5
- =lxqt-base/liblxqt-$(ver_cut 1-2)*
- sys-libs/zlib:=
- x11-apps/setxkbmap
- x11-libs/libxcb:=
- x11-libs/libX11
- x11-libs/libXcursor
- x11-libs/libXfixes
- monitor? ( kde-plasma/libkscreen:5= )
-"
-DEPEND="${DEPEND}
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.5.0
-"
-
-PATCHES=( "${FILESDIR}/${P}-remove-dependency-on-QtConcurrent.patch" )
-
-src_configure() {
- local mycmakeargs=(
- -DPULL_TRANSLATIONS=OFF
- -DWITH_MONITOR="$(usex monitor)"
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- doman man/*.1 liblxqt-config-cursor/man/*.1 lxqt-config-appearance/man/*.1
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}