summaryrefslogtreecommitdiff
path: root/lxde-base/lxsession/files
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxsession/files')
-rw-r--r--lxde-base/lxsession/files/lxsession-0.5.2-fix-invalid-memcpy.patch20
-rw-r--r--lxde-base/lxsession/files/lxsession-0.5.2-key2-null.patch20
-rw-r--r--lxde-base/lxsession/files/lxsession-0.5.2-notify-daemon-default.patch13
-rw-r--r--lxde-base/lxsession/files/lxsession-0.5.2-reload.patch43
4 files changed, 96 insertions, 0 deletions
diff --git a/lxde-base/lxsession/files/lxsession-0.5.2-fix-invalid-memcpy.patch b/lxde-base/lxsession/files/lxsession-0.5.2-fix-invalid-memcpy.patch
new file mode 100644
index 000000000000..672889997688
--- /dev/null
+++ b/lxde-base/lxsession/files/lxsession-0.5.2-fix-invalid-memcpy.patch
@@ -0,0 +1,20 @@
+--- lxsession-0.5.2/lxsession-edit/lxsession-edit-common.c.memmove 2014-10-05 08:49:49.000000000 +0900
++++ lxsession-0.5.2/lxsession-edit/lxsession-edit-common.c 2016-02-15 19:21:23.780783021 +0900
+@@ -216,7 +216,7 @@ void update_enable_state(GKeyFile* kf, g
+ if( strcmp(list[i], session_name) == 0 )
+ {
+ g_free(list[i]);
+- memcpy( list + i, list + i + 1, (n-i) * sizeof(char*) );
++ memmove( list + i, list + i + 1, (n-i) * sizeof(char*) );
+ --n;
+ break;
+ }
+@@ -259,7 +259,7 @@ void update_enable_state(GKeyFile* kf, g
+ if( strcmp(list[i], session_name) == 0 )
+ {
+ g_free(list[i]);
+- memcpy( list + i, list + i + 1, (n-i) * sizeof(char*) );
++ memmove( list + i, list + i + 1, (n-i) * sizeof(char*) );
+ --n;
+ break;
+ }
diff --git a/lxde-base/lxsession/files/lxsession-0.5.2-key2-null.patch b/lxde-base/lxsession/files/lxsession-0.5.2-key2-null.patch
new file mode 100644
index 000000000000..31c88a9caa66
--- /dev/null
+++ b/lxde-base/lxsession/files/lxsession-0.5.2-key2-null.patch
@@ -0,0 +1,20 @@
+--- lxsession-0.5.2/lxsession/settings.vala.key2 2014-10-18 01:54:57.000000000 +0900
++++ lxsession-0.5.2/lxsession/settings.vala 2015-07-13 14:56:00.830117779 +0900
+@@ -56,7 +56,7 @@ namespace Lxsession
+ return return_map;
+ }
+
+- public void create_config_item (string categorie, string key1, string key2, string type, string? variable)
++ public void create_config_item (string categorie, string key1, string? key2, string type, string? variable)
+ {
+ /* only support string for now */
+ string item_key = categorie + ";" + key1 + ";" + key2 + ";";
+@@ -71,7 +71,7 @@ namespace Lxsession
+ update_support_keys (categorie, key1, key2);
+ }
+
+- public void delete_config_item (string categorie, string key1, string key2, string type)
++ public void delete_config_item (string categorie, string key1, string? key2, string type)
+ {
+ /* only support string for now */
+ string item_key = categorie + ";" + key1 + ";" + key2 + ";";
diff --git a/lxde-base/lxsession/files/lxsession-0.5.2-notify-daemon-default.patch b/lxde-base/lxsession/files/lxsession-0.5.2-notify-daemon-default.patch
new file mode 100644
index 000000000000..ffca8227209a
--- /dev/null
+++ b/lxde-base/lxsession/files/lxsession-0.5.2-notify-daemon-default.patch
@@ -0,0 +1,13 @@
+--- lxsession-0.5.2/lxsession/settings.vala.notify 2015-08-11 14:14:22.187535605 +0900
++++ lxsession-0.5.2/lxsession/settings.vala 2015-08-11 14:37:18.868694268 +0900
+@@ -258,6 +258,10 @@
+ set_generic_default("Session", "proxy_manager", "command", "string", "build-in");
+ set_generic_default("Session", "keyring", "command", "string", "ssh-agent");
+
++ set_generic_default("Session", "notification", "command", "string", "/usr/libexec/notification-daemon");
++ set_generic_default("Session", "notification", "autostart", "string", "true");
++
++
+ /* Set Xsettings default */
+
+ set_generic_default("GTK", "iXft", "Antialias", "string", "1");
diff --git a/lxde-base/lxsession/files/lxsession-0.5.2-reload.patch b/lxde-base/lxsession/files/lxsession-0.5.2-reload.patch
new file mode 100644
index 000000000000..d7e9164e7286
--- /dev/null
+++ b/lxde-base/lxsession/files/lxsession-0.5.2-reload.patch
@@ -0,0 +1,43 @@
+--- lxsession-0.5.2/Makefile.am.debug 2014-11-29 23:50:05.000000000 +0900
++++ lxsession-0.5.2/Makefile.am 2015-06-17 11:08:14.510501437 +0900
+@@ -424,6 +424,7 @@
+ --pkg gio-2.0 \
+ --pkg posix \
+ --pkg lxsettings-daemon \
++ --pkg xevent \
+ $(buildinclip_VALAFLAGS) \
+ $(buildinpolkit_VALAFLAGS) \
+ $(NULL)
+--- lxsession-0.5.2/lxsession/main.vala.debug 2014-10-05 08:49:49.000000000 +0900
++++ lxsession-0.5.2/lxsession/main.vala 2015-06-17 11:19:54.979024117 +0900
+@@ -96,6 +96,17 @@
+ return -1;
+ }
+
++ if (xevent_init() == false)
++ {
++ return 1;
++ }
++
++ if (reload == true)
++ {
++ send_internal_command(LXS_CMD.RELOAD);
++ return 0;
++ }
++
+ message ("Session is %s",session);
+ message ("DE is %s", desktop_environnement);
+
+--- lxsession-0.5.2/vapi/xevent.vapi.debug 2015-06-17 11:08:14.520501444 +0900
++++ lxsession-0.5.2/vapi/xevent.vapi 2015-06-17 11:20:16.384040089 +0900
+@@ -0,0 +1,10 @@
++[CCode (cprefix = "LxsessionXEvent", cheader_filename = "lxsettings-daemon/xevent.h")]
++ public static void send_internal_command( int cmd );
++ public static bool xevent_init();
++
++[CCode (cname = "int", cprefix = "LXS_", cheader_filename = "lxsettings-daemon/xevent.h", has_type_id = false)]
++ public enum LXS_CMD {
++ RELOAD,
++ EXIT,
++ LAST_CMD
++ }