summaryrefslogtreecommitdiff
path: root/lxde-base/lxdm/lxdm-0.5.3-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxdm/lxdm-0.5.3-r2.ebuild')
-rw-r--r--lxde-base/lxdm/lxdm-0.5.3-r2.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/lxde-base/lxdm/lxdm-0.5.3-r2.ebuild b/lxde-base/lxdm/lxdm-0.5.3-r2.ebuild
index b15ace55d6d0..cbc776c32d78 100644
--- a/lxde-base/lxdm/lxdm-0.5.3-r2.ebuild
+++ b/lxde-base/lxdm/lxdm-0.5.3-r2.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-# Using strip-linguas in eutils
-inherit eutils autotools systemd
+inherit l10n autotools systemd
DESCRIPTION="LXDE Display Manager"
HOMEPAGE="https://wiki.lxde.org/en/LXDM"
@@ -14,13 +13,11 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc x86"
-IUSE="debug elogind +gtk3 nls pam systemd"
+IUSE="debug elogind nls pam systemd"
DEPEND="
x11-libs/libxcb
- gtk3? ( x11-libs/gtk+:3 )
- !gtk3? ( x11-libs/gtk+:2 )
- nls? ( sys-devel/gettext )
+ x11-libs/gtk+:3
pam? ( sys-libs/pam )"
# We only use the pam modules and not actually link to the code
RDEPEND="${DEPEND}
@@ -28,7 +25,9 @@ RDEPEND="${DEPEND}
systemd? ( sys-apps/systemd[pam] )
"
BDEPEND=">=dev-util/intltool-0.40
- virtual/pkgconfig"
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
DOCS=( AUTHORS README TODO )
REQUIRED_USE="?? ( elogind systemd ) elogind? ( pam ) systemd? ( pam )"
@@ -59,7 +58,7 @@ src_configure() {
--with-xconn=xcb \
--with-systemdsystemunitdir=$(systemd_get_systemunitdir) \
--disable-consolekit \
- $(use_enable gtk3) \
+ --enable-gtk3 \
$(use_enable nls) \
$(use_enable debug) \
$(use_with pam)