summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-meta
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-meta')
-rw-r--r--kde-plasma/plasma-meta/Manifest3
-rw-r--r--kde-plasma/plasma-meta/metadata.xml6
-rw-r--r--kde-plasma/plasma-meta/plasma-meta-5.17.2.ebuild111
3 files changed, 117 insertions, 3 deletions
diff --git a/kde-plasma/plasma-meta/Manifest b/kde-plasma/plasma-meta/Manifest
index f0e203a79c73..71ca226f6e37 100644
--- a/kde-plasma/plasma-meta/Manifest
+++ b/kde-plasma/plasma-meta/Manifest
@@ -1,2 +1,3 @@
EBUILD plasma-meta-5.16.5.ebuild 3832 BLAKE2B 19e6f30fca31b3a3c77b13628497ff1ef48e5048c7b3bb59a4fb77d0dfd777d28bf792886ac34ceb3750113880a618c43e4459b24d63dce2a7b4437c2ee7d369 SHA512 c98d716c46660212508f411bc13c747363f06112338c981d98bf014c802689136ad2395984a1e2141154832cbc0d803898c709c5c2a064ce7e868f2fd7316b10
-MISC metadata.xml 1917 BLAKE2B 065db6335ecc51b0de9a52c3b44c77c6936ce27e765c960d908ffa87a84e2d88d584988d14689277b0577627127def243252d5b827d81856717e4f57f4e67092 SHA512 16224a45e1475917b3618b19f0e00d537d4183efee8d7a98c73fd7b1736ecc9471a64a2e130d2a4b385a139be40623e61c9bac20ec1b64502bc85b2dd8a2df9a
+EBUILD plasma-meta-5.17.2.ebuild 3960 BLAKE2B 73207243d312d2a90068f8035811018f7245e393675360bfe3b4a4cdc586e772236773b3f13998f9ed8b07cee48950ab18d18bfafc378316197bedb95e12bdaa SHA512 3888f71fb45319e2e22775b30433a12e0380e908fd800e15a9d7762dafa7b8151c78383d9a5e4b68af904a372d5b5b15135b3936eb76104129cb40e70da3a0c2
+MISC metadata.xml 2177 BLAKE2B 1d0ff2de7c1ab2df3ba81c26488c9304c9e36b660f7842e96e156772e5e54ea22b0c5c17c1fecf65ad6ab936b4c85d8686d8b902a828aa38b13b7e18fcdc8037 SHA512 44a71cd2ae64e007201eeb0bf9f4d6fe5d3b8eb623ba2413bee5ce1c6cbfe252de074fd86d6af213455f32f1e093a7d67cc612f49f09a4330033bc080c3b7c40
diff --git a/kde-plasma/plasma-meta/metadata.xml b/kde-plasma/plasma-meta/metadata.xml
index a019b78b13b0..0e4113c5df40 100644
--- a/kde-plasma/plasma-meta/metadata.xml
+++ b/kde-plasma/plasma-meta/metadata.xml
@@ -14,14 +14,16 @@
<flag name="display-manager">Pull in a graphical display manager</flag>
<flag name="elogind">Use <pkg>sys-auth/elogind</pkg> for session tracking</flag>
<flag name="grub">Pull in Breeze theme for <pkg>sys-boot/grub</pkg></flag>
- <flag name="gtk">Enable Breeze widget style and KCM for GTK2 and GTK3</flag>
+ <flag name="gtk">Enable Breeze widget style and system settings module for GTK+</flag>
<flag name="legacy-systray">Add support for legacy applications using <pkg>kde-plasma/xembed-sni-proxy</pkg></flag>
<flag name="pam">Enable support for kwallet auto-unlocking</flag>
<flag name="plymouth">Pull in Breeze theme for <pkg>sys-boot/plymouth</pkg></flag>
<flag name="pm-utils">Enable support for suspend/resume with <pkg>sys-power/pm-utils</pkg> when using <pkg>sys-auth/consolekit</pkg></flag>
<flag name="pulseaudio">Install Plasma applet for PulseAudio volume management</flag>
- <flag name="sddm">Pull in the <pkg>x11-misc/sddm</pkg> display manager and KCM</flag>
+ <flag name="qrcode">Enable support for easy WiFi network sharing using QR codes with <pkg>kde-plasma/plasma-nm</pkg></flag>
+ <flag name="sddm">Pull in the <pkg>x11-misc/sddm</pkg> display manager and system settings module</flag>
<flag name="sdk">Pull in <pkg>kde-plasma/plasma-sdk</pkg> for Plasma development</flag>
+ <flag name="thunderbolt">Pull in <pkg>kde-plasma/plasma-thunderbolt</pkg> control center module</flag>
<flag name="wallpapers">Install wallpapers for the Plasma Workspace</flag>
</use>
</pkgmetadata>
diff --git a/kde-plasma/plasma-meta/plasma-meta-5.17.2.ebuild b/kde-plasma/plasma-meta/plasma-meta-5.17.2.ebuild
new file mode 100644
index 000000000000..4ef623483cd1
--- /dev/null
+++ b/kde-plasma/plasma-meta/plasma-meta-5.17.2.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Merge this to pull in all Plasma 5 packages"
+HOMEPAGE="https://kde.org/plasma-desktop"
+
+LICENSE="metapackage"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="bluetooth +browser-integration consolekit crypt +desktop-portal discover
++display-manager elogind grub gtk +handbook +legacy-systray networkmanager pam
+plymouth +pm-utils pulseaudio qrcode +sddm sdk systemd +thunderbolt +wallpapers"
+
+REQUIRED_USE="?? ( consolekit elogind systemd )"
+
+RDEPEND="
+ >=kde-plasma/breeze-${PV}:${SLOT}
+ >=kde-plasma/drkonqi-${PV}:${SLOT}
+ >=kde-plasma/kactivitymanagerd-${PV}:${SLOT}
+ >=kde-plasma/kde-cli-tools-${PV}:${SLOT}
+ >=kde-plasma/kdecoration-${PV}:${SLOT}
+ >=kde-plasma/kdeplasma-addons-${PV}:${SLOT}
+ >=kde-plasma/kgamma-${PV}:${SLOT}
+ >=kde-plasma/khotkeys-${PV}:${SLOT}
+ >=kde-plasma/kinfocenter-${PV}:${SLOT}
+ >=kde-plasma/kmenuedit-${PV}:${SLOT}
+ >=kde-plasma/kscreen-${PV}:${SLOT}
+ >=kde-plasma/kscreenlocker-${PV}:${SLOT}
+ >=kde-plasma/ksshaskpass-${PV}:${SLOT}
+ >=kde-plasma/ksysguard-${PV}:${SLOT}
+ >=kde-plasma/kwayland-integration-${PV}:${SLOT}
+ >=kde-plasma/kwin-${PV}:${SLOT}
+ >=kde-plasma/kwrited-${PV}:${SLOT}
+ >=kde-plasma/libkscreen-${PV}:${SLOT}
+ >=kde-plasma/libksysguard-${PV}:${SLOT}
+ >=kde-plasma/milou-${PV}:${SLOT}
+ >=kde-plasma/oxygen-${PV}:${SLOT}
+ >=kde-plasma/plasma-desktop-${PV}:${SLOT}
+ >=kde-plasma/plasma-integration-${PV}:${SLOT}
+ >=kde-plasma/plasma-workspace-${PV}:${SLOT}
+ >=kde-plasma/polkit-kde-agent-${PV}:${SLOT}
+ >=kde-plasma/powerdevil-${PV}:${SLOT}
+ >=kde-plasma/systemsettings-${PV}:${SLOT}
+ >=kde-plasma/user-manager-${PV}:${SLOT}
+ sys-apps/dbus[elogind?,systemd?]
+ sys-auth/polkit[elogind?,systemd?]
+ sys-fs/udisks:2[elogind?,systemd?]
+ bluetooth? ( >=kde-plasma/bluedevil-${PV}:${SLOT} )
+ browser-integration? ( >=kde-plasma/plasma-browser-integration-${PV}:${SLOT} )
+ consolekit? (
+ >=sys-auth/consolekit-1.0.1
+ pm-utils? ( sys-power/pm-utils )
+ )
+ crypt? ( >=kde-plasma/plasma-vault-${PV}:${SLOT} )
+ desktop-portal? ( >=kde-plasma/xdg-desktop-portal-kde-${PV}:${SLOT} )
+ discover? ( >=kde-plasma/discover-${PV}:${SLOT} )
+ display-manager? (
+ sddm? (
+ >=kde-plasma/sddm-kcm-${PV}:${SLOT}
+ x11-misc/sddm[consolekit?,elogind?,systemd?]
+ )
+ !sddm? ( x11-misc/lightdm )
+ )
+ grub? ( >=kde-plasma/breeze-grub-${PV}:${SLOT} )
+ gtk? (
+ >=kde-plasma/breeze-gtk-${PV}:${SLOT}
+ >=kde-plasma/kde-gtk-config-${PV}:${SLOT}
+ )
+ handbook? ( kde-apps/khelpcenter:5 )
+ legacy-systray? ( >=kde-plasma/xembed-sni-proxy-${PV}:${SLOT} )
+ networkmanager? (
+ >=kde-plasma/plasma-nm-${PV}:${SLOT}
+ net-misc/networkmanager[consolekit?,elogind?,systemd?]
+ qrcode? ( kde-frameworks/prison[qml] )
+ )
+ pam? (
+ >=kde-plasma/kwallet-pam-${PV}:${SLOT}
+ sys-auth/pambase[consolekit?,elogind?,systemd?]
+ )
+ plymouth? (
+ >=kde-plasma/breeze-plymouth-${PV}:${SLOT}
+ >=kde-plasma/plymouth-kcm-${PV}:${SLOT}
+ )
+ pulseaudio? ( >=kde-plasma/plasma-pa-${PV}:${SLOT} )
+ sdk? ( >=kde-plasma/plasma-sdk-${PV}:${SLOT} )
+ thunderbolt? ( >=kde-plasma/plasma-thunderbolt-${PV}:${SLOT} )
+ wallpapers? ( >=kde-plasma/plasma-workspace-wallpapers-${PV}:${SLOT} )
+"
+
+pkg_postinst() {
+ local i selected use_pkg_map=(
+ consolekit:sys-auth/consolekit
+ elogind:sys-auth/elogind
+ systemd:sys-apps/systemd
+ )
+ for i in ${use_pkg_map[@]}; do
+ use ${i%:*} && selected="${i%:*}"
+ done
+ for i in ${use_pkg_map[@]}; do
+ if ! use ${i%:*} && has_version ${i#*:}; then
+ ewarn "An existing installation of ${i#*:} was detected even though"
+ ewarn "${PN} was configured with USE ${selected} instead of ${i%:*}."
+ ewarn "There can only be one session manager at runtime, otherwise random issues"
+ ewarn "may occur. Please make sure USE ${i%:*} is nowhere enabled in make.conf"
+ ewarn "or package.use and remove ${i#*:} before raising bugs."
+ ewarn "For more information, visit https://wiki.gentoo.org/wiki/KDE"
+ fi
+ done
+}