summaryrefslogtreecommitdiff
path: root/kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild')
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild48
1 files changed, 13 insertions, 35 deletions
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild
index 2560f8c7928d..78ba5b38ae68 100644
--- a/kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.18.5.ebuild
@@ -12,24 +12,12 @@ VIRTUALX_REQUIRED="test"
inherit ecm kde.org
DESCRIPTION="KDE Plasma desktop"
-
-# Avoid pulling in xf86-input-{evdev,libinput,synaptics} DEPENDs
-# just for 1 header each. touchpad also uses a header from xorg-server.
-SHA_EVDEV="425ed601"
-SHA_LIBINPUT="e52daf20"
-SHA_SYNAPTICS="383355fa"
-SHA_XSERVER="d511a301"
-XORG_URI="https://gitlab.freedesktop.org/xorg/driver/PKG/-/raw"
-SRC_URI+="
- ${XORG_URI/PKG/xf86-input-evdev}/${SHA_EVDEV}/include/evdev-properties.h -> evdev-properties.h-${SHA_EVDEV}
- ${XORG_URI/PKG/xf86-input-libinput}/${SHA_LIBINPUT}/include/libinput-properties.h -> libinput-properties.h-${SHA_LIBINPUT}
- ${XORG_URI/PKG/xf86-input-synaptics}/${SHA_SYNAPTICS}/include/synaptics-properties.h -> synaptics-properties.h-${SHA_SYNAPTICS}
- ${XORG_URI/driver\/PKG/xserver}/${SHA_XSERVER}/include/xserver-properties.h -> xserver-properties.h-${SHA_XSERVER}
-"
+XORGHDRS="${PN}-override-include-dirs-0"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${XORGHDRS}.tar.xz"
LICENSE="GPL-2" # TODO: CHECK
SLOT="5"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
IUSE="+fontconfig ibus scim +semantic-desktop"
COMMON_DEPEND="
@@ -129,29 +117,18 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=(
"${FILESDIR}/${PN}-5.18.4.1-synaptics-header.patch" # in Plasma/5.19
"${FILESDIR}/${P}-findxorgserver.patch" # in Plasma/5.19
- "${FILESDIR}/${P}-override-include-dirs.patch" # downstream patch
-)
+ "${WORKDIR}/${XORGHDRS}/override-include-dirs.patch" # downstream patch
-src_unpack() {
- kde.org_src_unpack
- mkdir "${WORKDIR}/include" || die "Failed to prepare evdev/libinput dir"
- cp "${DISTDIR}"/evdev-properties.h-${SHA_EVDEV} \
- "${WORKDIR}"/include/evdev-properties.h || die "Failed to copy evdev"
- cp "${DISTDIR}"/libinput-properties.h-${SHA_LIBINPUT} \
- "${WORKDIR}"/include/libinput-properties.h || die "Failed to copy libinput"
- cp "${DISTDIR}"/synaptics-properties.h-${SHA_SYNAPTICS} \
- "${WORKDIR}"/include/synaptics-properties.h || die "Failed to copy synaptics"
- cp "${DISTDIR}"/xserver-properties.h-${SHA_XSERVER} \
- "${WORKDIR}"/include/xserver-properties.h || die "Failed to copy xserver"
-}
+ "${FILESDIR}/${P}-KColorSchemeEditor-blurry-icons.patch" # in Plasma/5.18
+)
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package fontconfig Fontconfig)
- -DEvdev_INCLUDE_DIRS="${WORKDIR}"/include
- -DXORGLIBINPUT_INCLUDE_DIRS="${WORKDIR}"/include
- -DXORGSERVER_INCLUDE_DIRS="${WORKDIR}"/include
- -DSynaptics_INCLUDE_DIRS="${WORKDIR}"/include
+ -DEvdev_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGLIBINPUT_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DXORGSERVER_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
+ -DSynaptics_INCLUDE_DIRS="${WORKDIR}/${XORGHDRS}"/include
$(cmake_use_find_package ibus IBus)
$(cmake_use_find_package scim SCIM)
$(cmake_use_find_package semantic-desktop KF5Baloo)
@@ -162,10 +139,11 @@ src_configure() {
src_test() {
# parallel tests fail, foldermodeltest,positionertest hang, bug #646890
- # needs D-Bus, bug #634166
+ # test_kio_fonts needs D-Bus, bug #634166
+ # lookandfeel-kcmTest is unreliable for a long time, bug #607918
local myctestargs=(
-j1
- -E "(foldermodeltest|positionertest|test_kio_fonts)"
+ -E "(foldermodeltest|positionertest|test_kio_fonts|lookandfeel-kcmTest)"
)
ecm_src_test