summaryrefslogtreecommitdiff
path: root/kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild')
-rw-r--r--kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild b/kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild
new file mode 100644
index 000000000000..79902f136700
--- /dev/null
+++ b/kde-plasma/layer-shell-qt/layer-shell-qt-5.22.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Qt component to allow applications make use of Wayland wl-layer-shell protocol"
+
+LICENSE="LGPL-3+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/wayland-1.15
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5[X]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}
+ dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"