summaryrefslogtreecommitdiff
path: root/kde-misc/yakuake/yakuake-3.0.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-misc/yakuake/yakuake-3.0.4-r2.ebuild')
-rw-r--r--kde-misc/yakuake/yakuake-3.0.4-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/kde-misc/yakuake/yakuake-3.0.4-r2.ebuild b/kde-misc/yakuake/yakuake-3.0.4-r2.ebuild
new file mode 100644
index 000000000000..e82c0cbc12da
--- /dev/null
+++ b/kde-misc/yakuake/yakuake-3.0.4-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Quake-style terminal emulator based on konsole"
+HOMEPAGE="https://yakuake.kde.org/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwayland)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep konsole)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+"
+RDEPEND="${DEPEND}
+ !kde-misc/yakuake:4
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-qicon.patch"
+ "${FILESDIR}/${P}-qt-5.9-wayland.patch"
+ "${FILESDIR}/${P}-qdbus-crash.patch"
+)