summaryrefslogtreecommitdiff
path: root/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild')
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild
new file mode 100644
index 000000000000..1cb111a4cf42
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.98.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="nls"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}