summaryrefslogtreecommitdiff
path: root/kde-frameworks/kio/files
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kio/files')
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch31
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch53
-rw-r--r--kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch76
-rw-r--r--kde-frameworks/kio/files/kio-5.85.0-KDirOperator-exp-to-url-only-in-detail-treeview.patch54
-rw-r--r--kde-frameworks/kio/files/kio-5.85.0-allow-edit-icons-for-root-owned-desktop-files.patch32
5 files changed, 86 insertions, 160 deletions
diff --git a/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch b/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
deleted file mode 100644
index 26383b788a01..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-cxx17-std-mem_fn.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 36f1814b184f4d5ac628fca5db5f6cc1440b4db7 Mon Sep 17 00:00:00 2001
-From: Jan Paul Batrina <jpmbatrina01@gmail.com>
-Date: Mon, 12 Jul 2021 22:06:19 +0800
-Subject: [PATCH] Use std::mem_fn instead of the deprecated/removed
- std::mem_fun
-
-std::mem_fun was deprecated in C++11 and removed from
-the standard in C++17.
-
-BUG: 439780
-NO_CHANGELOG
----
- src/widgets/kpropertiesdialog.cpp | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/widgets/kpropertiesdialog.cpp b/src/widgets/kpropertiesdialog.cpp
-index 3f61e8ea3..1ed8bc7d8 100644
---- a/src/widgets/kpropertiesdialog.cpp
-+++ b/src/widgets/kpropertiesdialog.cpp
-@@ -2273,7 +2273,7 @@ void KFilePermissionsPropsPlugin::slotShowAdvancedPermissions()
- d->fileSystemSupportsACLs = fileSystemSupportsACL(path);
- }
- if (d->fileSystemSupportsACLs) {
-- std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fun(&QWidget::hide));
-+ std::for_each(theNotSpecials.begin(), theNotSpecials.end(), std::mem_fn(&QWidget::hide));
- extendedACLs = new KACLEditWidget(&dlg);
- extendedACLs->setEnabled(d->canChangePermissions);
- vbox->addWidget(extendedACLs);
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch b/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
deleted file mode 100644
index cdccada57d97..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-fix-open-url-w-binary.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 8ad6921524c92a0cf1b58336b3ce29e159e83b7d Mon Sep 17 00:00:00 2001
-From: David Edmundson <kde@davidedmundson.co.uk>
-Date: Wed, 14 Jul 2021 17:06:59 +0100
-Subject: [PATCH] Fix selecting binaries from component chooser KCM
-
-In the kcmshell for a component chooser we use the open with dialog to
-select services for various scheme handlers.
-
-If you select a binary instead of a .desktop file a temporary .desktop
-file is created in ~/.local/share/applications
-
-This is in the format
-Exec=someBinary
-MimeType=x-scheme-handler/http
-
-When we then use this application for launching KIO::DesktopExecParser
-then (sort of correctly) determines that that the chosen service cannot
-handle the http scheme because even though it is a scheme handler it
-does not have a "%u" in the exec line.
-
-This leads to us potentially loading websites via kioclient or kio-fuse.
-
-Testing done:
- - kcmshell5 component chooser
- - web browser -> other -> type "/usr/bin/firefox"
- - kde-open5 http://kde.org
- - Previously this gave a local URL, now it is correct
----
- src/widgets/kopenwithdialog.cpp | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/src/widgets/kopenwithdialog.cpp b/src/widgets/kopenwithdialog.cpp
-index 1831878ca..31295044d 100644
---- a/src/widgets/kopenwithdialog.cpp
-+++ b/src/widgets/kopenwithdialog.cpp
-@@ -1088,6 +1088,14 @@ bool KOpenWithDialogPrivate::checkAccept()
- KConfigGroup cg = desktopFile.desktopGroup();
- cg.writeEntry("Type", "Application");
- cg.writeEntry("Name", initialServiceName);
-+
-+ // if we select a binary for a scheme handler, then it's safe to assume it can handle URLs
-+ if (qMimeType.startsWith(QLatin1String("x-scheme-handler/"))) {
-+ if (!typedExec.contains(QLatin1String("%u"), Qt::CaseInsensitive) && !typedExec.contains(QLatin1String("%f"), Qt::CaseInsensitive)) {
-+ fullExec += QStringLiteral(" %u");
-+ }
-+ }
-+
- cg.writeEntry("Exec", fullExec);
- cg.writeEntry("NoDisplay", true); // don't make it appear in the K menu
- if (terminal->isChecked()) {
---
-GitLab
-
diff --git a/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch b/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch
deleted file mode 100644
index 033b75bb00b1..000000000000
--- a/kde-frameworks/kio/files/kio-5.84.0-fix-qtconcurrent-private-link.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-From fb9bbb6f1fbb4e6232221a851f55ca2dc43b012c Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Fri, 23 Apr 2021 20:10:31 +0200
-Subject: [PATCH] Introduce KIO_NO_PUBLIC_QTCONCURRENT option
-
-If set, move Qt5Concurrent to private link interface, drop from
-KF5KIOConfig.cmake.in. Originally added in 2f83dde2, but only used
-in the implementation, not the API.
-
-Test-built various revdeps successfully against the patched KIO
-with/without Qt5Concurrent installed, fixing implicit deps while
-at it. KDE Gear packages fixed in >=21.04.2, Plasma in >=5.21.5.
-
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CMakeLists.txt | 3 +++
- KF5KIOConfig.cmake.in | 2 ++
- src/core/CMakeLists.txt | 7 ++++++-
- 3 files changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index e0063c2c..63aef43c 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -49,6 +49,9 @@ option(KIO_ASSERT_SLAVE_STATES
- "Used to control whether slave state assertions are enabled. When not enabled only warnings are generated."
- ${ASSERT_SLAVE_STATES_DEFAULT})
-
-+# TODO KF6: remove
-+option(KIO_NO_PUBLIC_QTCONCURRENT "Privatize QtConcurrent linking, so KIO does not provide the target to revdeps.")
-+
- option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)" OFF)
- add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. Qt Assistant, Qt Creator & KDevelop)")
-
-diff --git a/KF5KIOConfig.cmake.in b/KF5KIOConfig.cmake.in
-index 687ec512..69564b3d 100644
---- a/KF5KIOConfig.cmake.in
-+++ b/KF5KIOConfig.cmake.in
-@@ -21,7 +21,9 @@ find_dependency(KF5WindowSystem "@KF_DEP_VERSION@")
- endif()
-
- find_dependency(Qt5Network "@REQUIRED_QT_VERSION@")
-+if (NOT @KIO_NO_PUBLIC_QTCONCURRENT@)
- find_dependency(Qt5Concurrent "@REQUIRED_QT_VERSION@")
-+endif()
- find_dependency(Qt5DBus "@REQUIRED_QT_VERSION@")
-
- include("${CMAKE_CURRENT_LIST_DIR}/KF5KIOTargets.cmake")
-diff --git a/src/core/CMakeLists.txt b/src/core/CMakeLists.txt
-index c09d408a..f6efee23 100644
---- a/src/core/CMakeLists.txt
-+++ b/src/core/CMakeLists.txt
-@@ -201,7 +201,6 @@ PUBLIC
- KF5::CoreAddons # KJob
- KF5::Service # TODO KF6 move to PRIVATE
- Qt5::Network
-- Qt5::Concurrent # QtConcurrentRun in hostinfo.cpp # TODO KF6 move to PRIVATE
- Qt5::DBus
- PRIVATE
- Qt5::Xml # davjob.cpp uses QDom
-@@ -211,6 +210,12 @@ PRIVATE
- KF5::DBusAddons # KDEInitInterface
- )
-
-+if(KIO_NO_PUBLIC_QTCONCURRENT)
-+ target_link_libraries(KF5KIOCore PRIVATE Qt5::Concurrent) # QtConcurrentRun in hostinfo.cpp
-+else()
-+ target_link_libraries(KF5KIOCore PUBLIC Qt5::Concurrent) # TODO KF6: remove
-+endif()
-+
- if (UNIX)
- target_link_libraries(KF5KIOCore PRIVATE KF5::AuthCore) #SlaveBase uses KAuth::Action
- endif()
---
-2.32.0
-
diff --git a/kde-frameworks/kio/files/kio-5.85.0-KDirOperator-exp-to-url-only-in-detail-treeview.patch b/kde-frameworks/kio/files/kio-5.85.0-KDirOperator-exp-to-url-only-in-detail-treeview.patch
new file mode 100644
index 000000000000..54365b694fa6
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.85.0-KDirOperator-exp-to-url-only-in-detail-treeview.patch
@@ -0,0 +1,54 @@
+From 51737430fcd963a04a4eddbb166114ae25430814 Mon Sep 17 00:00:00 2001
+From: Ahmad Samir <a.samirh78@gmail.com>
+Date: Wed, 4 Aug 2021 23:22:10 +0200
+Subject: [PATCH] KDirOperator: expand to url only in detail tree view
+
+When "allow expansion" is disabled in the menu, the view type is KFile::Tree,
+however when selecting an item from the location (Name:) combobox history,
+the item model would expand to show the file; that should only happen if
+"allow expansion" is enabled, i.e. when the view type is KFile::DetailTree.
+
+BUG: 440475
+FIXED-IN: 5.86
+
+asturm 2021-08-15: fixed by merge with 8039f8b399757001ffa919ef56ede283c287dcd4
+---
+ src/filewidgets/kdiroperator.cpp | 13 +++++++++++--
+ 1 file changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/src/filewidgets/kdiroperator.cpp b/src/filewidgets/kdiroperator.cpp
+index bc80d93fe..7af20a057 100644
+--- a/src/filewidgets/kdiroperator.cpp
++++ b/src/filewidgets/kdiroperator.cpp
+@@ -1870,7 +1870,11 @@ void KDirOperator::setCurrentItem(const QUrl &url)
+ KFileItem item = d->m_dirLister->findByUrl(url);
+ if (d->m_shouldFetchForItems && item.isNull()) {
+ d->m_itemsToBeSetAsCurrent << url;
+- d->m_dirModel->expandToUrl(url);
++
++ if (d->m_viewKind == KFile::DetailTree) {
++ d->m_dirModel->expandToUrl(url);
++ }
++
+ return;
+ }
+
+@@ -1909,9 +1913,14 @@ void KDirOperator::setCurrentItems(const QList<QUrl> &urls)
+ KFileItem item = d->m_dirLister->findByUrl(url);
+ if (d->m_shouldFetchForItems && item.isNull()) {
+ d->m_itemsToBeSetAsCurrent << url;
+- d->m_dirModel->expandToUrl(url);
++
++ if (d->m_viewKind == KFile::DetailTree) {
++ d->m_dirModel->expandToUrl(url);
++ }
++
+ continue;
+ }
++
+ itemList << item;
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/kio/files/kio-5.85.0-allow-edit-icons-for-root-owned-desktop-files.patch b/kde-frameworks/kio/files/kio-5.85.0-allow-edit-icons-for-root-owned-desktop-files.patch
new file mode 100644
index 000000000000..34a70a827e03
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.85.0-allow-edit-icons-for-root-owned-desktop-files.patch
@@ -0,0 +1,32 @@
+From 2187b62588b060bc27143dd326b5171aec930454 Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Sat, 7 Aug 2021 19:38:43 +0000
+Subject: [PATCH] [kpropertiesdialog] Allow editing icons for root-owned
+ desktop files
+
+---
+ src/widgets/kpropertiesdialog.cpp | 8 ++++++++
+ 1 file changed, 8 insertions(+)
+
+diff --git a/src/widgets/kpropertiesdialog.cpp b/src/widgets/kpropertiesdialog.cpp
+index 76155338e..2288ccc08 100644
+--- a/src/widgets/kpropertiesdialog.cpp
++++ b/src/widgets/kpropertiesdialog.cpp
+@@ -1206,6 +1206,14 @@ KFilePropsPlugin::KFilePropsPlugin(KPropertiesDialog *_props)
+ bool KFilePropsPlugin::enableIconButton() const
+ {
+ const KFileItem item = properties->item();
++
++ // desktop files are special, files in /usr/share/applications can be
++ // edited by overlaying them in .local/share/applications
++ // https://bugs.kde.org/show_bug.cgi?id=429613
++ if (item.isDesktopFile()) {
++ return true;
++ }
++
+ // If the current item is a directory, check if it's writable,
+ // so we can create/update a .directory
+ // Current item is a file, same thing: check if it is writable
+--
+GitLab
+