summaryrefslogtreecommitdiff
path: root/kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild')
-rw-r--r--kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild b/kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild
new file mode 100644
index 000000000000..6c6f658b72cf
--- /dev/null
+++ b/kde-frameworks/kemoticons/kemoticons-5.85.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for converting text emoticons to graphical representations"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+# requires running kde environment
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+"
+RDEPEND="${DEPEND}"