summaryrefslogtreecommitdiff
path: root/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild')
-rw-r--r--kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild
index 08a4d2f25a21..3210f0803045 100644
--- a/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild
+++ b/kde-frameworks/extra-cmake-modules/extra-cmake-modules-5.112.0.ebuild
@@ -11,11 +11,12 @@ DESCRIPTION="Extra modules and scripts for CMake"
HOMEPAGE="https://invent.kde.org/frameworks/extra-cmake-modules"
LICENSE="BSD"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="~amd64 arm ~arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~x86"
IUSE="doc test"
RESTRICT="!test? ( test )"
+RDEPEND="app-arch/libarchive[bzip2]"
BDEPEND="
doc? (
${PYTHON_DEPS}
@@ -27,14 +28,12 @@ BDEPEND="
>=dev-qt/qtcore-${QTMIN}:5
)
"
-RDEPEND="
- app-arch/libarchive[bzip2]
-"
PATCHES=(
"${FILESDIR}/${PN}-5.49.0-no-fatal-warnings.patch"
"${FILESDIR}/${PN}-5.93.0-skip-ecm_add_test-early.patch"
"${FILESDIR}/${PN}-5.93.0-disable-qmlplugindump.patch"
+ "${FILESDIR}/${PN}-5.112.0-disable-tests-requiring-PyQt5.patch" # bug 680256
)
python_check_deps() {
@@ -45,13 +44,6 @@ pkg_setup() {
use doc && python-any-r1_pkg_setup
}
-src_prepare() {
- cmake_src_prepare
- # Requires PyQt5, bug #680256
- sed -i -e "/^if(NOT SIP_Qt5Core_Mod_FILE)/s/NOT SIP_Qt5Core_Mod_FILE/TRUE/" \
- tests/CMakeLists.txt || die "failed to disable GenerateSipBindings tests"
-}
-
src_configure() {
local mycmakeargs=(
-DDOC_INSTALL_DIR=/usr/share/doc/"${PF}"