summaryrefslogtreecommitdiff
path: root/kde-apps/mailcommon/mailcommon-21.08.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/mailcommon/mailcommon-21.08.0.ebuild')
-rw-r--r--kde-apps/mailcommon/mailcommon-21.08.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/kde-apps/mailcommon/mailcommon-21.08.0.ebuild b/kde-apps/mailcommon/mailcommon-21.08.0.ebuild
new file mode 100644
index 000000000000..3daac8b559b6
--- /dev/null
+++ b/kde-apps/mailcommon/mailcommon-21.08.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.84.0
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Common mail library"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+RESTRICT+=" test"
+
+DEPEND="
+ >=dev-qt/qtcore-${QTMIN}:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/grantleetheme-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-apps/kpimtextedit-${PVCUT}:5
+ >=kde-apps/libkdepim-${PVCUT}:5
+ >=kde-apps/mailimporter-${PVCUT}:5
+ >=kde-apps/messagelib-${PVCUT}:5
+ >=kde-apps/pimcommon-${PVCUT}:5
+ >=kde-frameworks/karchive-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcontacts-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kitemviews-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ >=kde-frameworks/syntax-highlighting-${KFMIN}:5
+ >=media-libs/phonon-4.11.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/libxslt"