summaryrefslogtreecommitdiff
path: root/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild')
-rw-r--r--kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild b/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild
new file mode 100644
index 000000000000..cc8cce8da0e1
--- /dev/null
+++ b/kde-apps/calendarjanitor/calendarjanitor-24.05.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoff"
+ECM_TEST="false"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Tool to scan calendar data for buggy instances"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[widgets]
+ >=kde-apps/akonadi-${PVCUT}:6
+ >=kde-apps/akonadi-calendar-${PVCUT}:6
+ >=kde-apps/calendarsupport-${PVCUT}:6
+ >=kde-frameworks/kcalendarcore-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-loggingcategory.patch" )
+
+src_prepare() {
+ ecm_src_prepare
+ cmake_comment_add_subdirectory doc konsolekalendar
+
+ # delete colliding konsolekalendar translations
+ rm -f po/*/konsolekalendar.po || die
+ rm -rf po/*/docs/konsolekalendar || die
+}