summaryrefslogtreecommitdiff
path: root/gui-libs
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/Manifest.gzbin4963 -> 4964 bytes
-rw-r--r--gui-libs/wlroots/Manifest1
-rw-r--r--gui-libs/wlroots/wlroots-0.17.3-r2.ebuild109
3 files changed, 110 insertions, 0 deletions
diff --git a/gui-libs/Manifest.gz b/gui-libs/Manifest.gz
index fd7fb2769168..21b3947ef874 100644
--- a/gui-libs/Manifest.gz
+++ b/gui-libs/Manifest.gz
Binary files differ
diff --git a/gui-libs/wlroots/Manifest b/gui-libs/wlroots/Manifest
index 0dcba160184b..7263cd3ed7fe 100644
--- a/gui-libs/wlroots/Manifest
+++ b/gui-libs/wlroots/Manifest
@@ -7,5 +7,6 @@ EBUILD wlroots-0.15.1-r2.ebuild 1962 BLAKE2B 90615bf555b7368bbb66f43749b438e5bbe
EBUILD wlroots-0.16.2-r3.ebuild 2046 BLAKE2B 18719f44961b03b867bc8f17cfadbc23c0bdd16e22482f76c78eb6daccae21aa3f26e1d487555a5783094848e53c0595cc4e8317ad06e57bb5ec5801c0a25b21 SHA512 9713a3bb3e4f2c6706ead4c4adacb16670420c39c0c4e911c555d9f64a77bb70a2d528fc6e4a24053c6645d593d588af47e7b7e73f36d5275791a3996ad5d607
EBUILD wlroots-0.17.2-r1.ebuild 2223 BLAKE2B 978951dcb04c75f4801139e1141f154afb5d0f38b23d723a15c131897b7b2c03a109f178717dd88c595934ad491fa56c0b7f8c56f2b5d607c795ba61ffbac8a5 SHA512 c2b05ceeabb336dd992e564df6375debdaeae9b2331a234ed92779b5a44114f7c7c26bad9188fb9de7cf25e401531c2285228848315b369a4e1cfcdf2711a89b
EBUILD wlroots-0.17.3-r1.ebuild 2227 BLAKE2B 8791359f93d106db37b060c5b8e00ee6241ef0c3f5c2404664b6e1e8d9e0b63e39854fb6730e9dc8de1c24d4a8516a4d0f60528df4bc5cabcc7404289b4ad36d SHA512 0b9c86b4f08b415a1e244a5e135b18957003f180751e5acb0b95f70f79f41bcbd6b3ecad0fe9fd8288dfb966e9a5c280a64799e3f79f14d3961edf78d829d146
+EBUILD wlroots-0.17.3-r2.ebuild 2292 BLAKE2B 77d67f15f50a5b5ee0b195ecf93454ac47e2507a6b150a34a776f4006ad1712dc462446143fb05d9ebef7005e88b6cfda1174cc1b3158aa80854d8233582d3d7 SHA512 842f7d205419958aef09bc29eaf01a9864181ab5792a78befd58feffe841646ca3bdf6b0e329c2130d766a3bf31cac5f6c6b7583d637a4254b3b64cb83157db0
EBUILD wlroots-9999.ebuild 2225 BLAKE2B 434f6b6d19dca2fac42ea80aceaee5cdcb98111037b229eb4c780fb284b80d24dd6204985ca54d4df29d7e11ef8bb65bddf881d8d677f0b805db6d86a4fbd83f SHA512 65d52eba8909bb31cf8deb6980e15c32d7864b44ab659b0c09c87b1155a17135763243e87f2df8542f7fcb0d0ccfcf909b390736d8163d82d93f0096ee88a994
MISC metadata.xml 2145 BLAKE2B 75225f805364003c244a52d4a46c826e5a283ed01ef71d32b73fdcc03f6a1b46f0083a43be4c2079c6614c1b5db8a07a9a17ce2501c5eb65a53b83a7af13cdd0 SHA512 45faf9ad055a9b670ace556b1639f355b96da462447a33a655e36960fe99ef42c5c6c591ee39b4554ddd276e70c492c83c7ff4a844034ac1a1e25b39b465b5f3
diff --git a/gui-libs/wlroots/wlroots-0.17.3-r2.ebuild b/gui-libs/wlroots/wlroots-0.17.3-r2.ebuild
new file mode 100644
index 000000000000..8dc3bc02f4a2
--- /dev/null
+++ b/gui-libs/wlroots/wlroots-0.17.3-r2.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Pluggable, composable, unopinionated modules for building a Wayland compositor"
+HOMEPAGE="https://gitlab.freedesktop.org/wlroots/wlroots"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/${PN}/${PN}.git"
+ inherit git-r3
+ SLOT="0/9999"
+else
+ SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/releases/${PV}/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+ SLOT="0/$(ver_cut 2)"
+fi
+
+LICENSE="MIT"
+IUSE="liftoff +libinput +drm +session tinywl vulkan x11-backend xcb-errors X"
+REQUIRED_USE="
+ drm? ( session )
+ libinput? ( session )
+ xcb-errors? ( || ( x11-backend X ) )
+"
+
+RDEPEND="
+ >=dev-libs/wayland-1.22.0
+ media-libs/libglvnd
+ || (
+ >=media-libs/mesa-24.1.0_rc1[opengl]
+ <media-libs/mesa-24.1.0_rc1[egl(+),gles2]
+ )
+ >=x11-libs/libdrm-2.4.114
+ x11-libs/libxkbcommon
+ >=x11-libs/pixman-0.42.0
+ drm? (
+ media-libs/libdisplay-info
+ sys-apps/hwdata
+ liftoff? ( dev-libs/libliftoff )
+ )
+ libinput? ( >=dev-libs/libinput-1.14.0:= )
+ session? (
+ sys-auth/seatd:=
+ virtual/libudev
+ )
+ vulkan? (
+ dev-util/glslang:=
+ dev-util/vulkan-headers
+ media-libs/vulkan-loader
+ )
+ xcb-errors? ( x11-libs/xcb-util-errors )
+ x11-backend? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-renderutil
+ )
+ X? (
+ x11-libs/libxcb:=
+ x11-libs/xcb-util-wm
+ x11-base/xwayland
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ liftoff? (
+ >=dev-libs/libliftoff-0.4
+ <dev-libs/libliftoff-0.5
+ )
+"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.32
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local backends=(
+ $(usev drm)
+ $(usev libinput)
+ $(usev x11-backend 'x11')
+ )
+ local meson_backends=$(IFS=','; echo "${backends[*]}")
+ local emesonargs=(
+ $(meson_feature xcb-errors)
+ $(meson_use tinywl examples)
+ -Drenderers=$(usex vulkan 'gles2,vulkan' gles2)
+ $(meson_feature X xwayland)
+ -Dbackends=${meson_backends}
+ $(meson_feature session)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dodoc docs/*
+
+ if use tinywl; then
+ dobin "${BUILD_DIR}"/tinywl/tinywl
+ fi
+}
+
+pkg_postinst() {
+ elog "You must be in the input group to allow your compositor"
+ elog "to access input devices via libinput."
+}