summaryrefslogtreecommitdiff
path: root/gui-libs/libwpe/libwpe-1.14.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-libs/libwpe/libwpe-1.14.2.ebuild')
-rw-r--r--gui-libs/libwpe/libwpe-1.14.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/gui-libs/libwpe/libwpe-1.14.2.ebuild b/gui-libs/libwpe/libwpe-1.14.2.ebuild
new file mode 100644
index 000000000000..034047a9d0a7
--- /dev/null
+++ b/gui-libs/libwpe/libwpe-1.14.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Platform-agnostic interfaces for WPE WebKit"
+HOMEPAGE="https://wpewebkit.org/"
+SRC_URI="https://wpewebkit.org/releases/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="1.0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ media-libs/mesa[egl(+)]
+ x11-libs/libxkbcommon
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Denable-xkb=true
+ -Dbuild-docs=false # hotdoc not packaged
+ )
+ meson_src_configure
+}