summaryrefslogtreecommitdiff
path: root/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild')
-rw-r--r--gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild b/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild
new file mode 100644
index 000000000000..49a565608a88
--- /dev/null
+++ b/gui-apps/wl-clipboard/wl-clipboard-2.0.0_beta2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Wayland clipboard utilities"
+HOMEPAGE="https://github.com/bugaevc/wl-clipboard"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bugaevc/${PN}.git"
+else
+ SRC_URI="https://github.com/bugaevc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/wayland"
+RDEPEND="${DEPEND}"
+BDEPEND=""