summaryrefslogtreecommitdiff
path: root/gui-apps/wf-recorder/wf-recorder-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wf-recorder/wf-recorder-9999.ebuild')
-rw-r--r--gui-apps/wf-recorder/wf-recorder-9999.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/gui-apps/wf-recorder/wf-recorder-9999.ebuild b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
index fd58d11409c9..3a7ded597607 100644
--- a/gui-apps/wf-recorder/wf-recorder-9999.ebuild
+++ b/gui-apps/wf-recorder/wf-recorder-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020-2023 Gentoo Authors
+# Copyright 2020-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -18,11 +18,13 @@ fi
LICENSE="MIT"
SLOT="0"
+IUSE="pulseaudio"
DEPEND="
dev-libs/wayland
- media-libs/libpulse
- media-video/ffmpeg[pulseaudio,x264]
+ media-libs/mesa[wayland]
+ media-video/ffmpeg[pulseaudio?,x264]
+ pulseaudio? ( media-libs/libpulse )
"
RDEPEND="${DEPEND}"
BDEPEND="
@@ -30,3 +32,10 @@ BDEPEND="
dev-util/wayland-scanner
virtual/pkgconfig
"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature pulseaudio pulse)
+ )
+ meson_src_configure
+}