summaryrefslogtreecommitdiff
path: root/gui-apps/wcm/wcm-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/wcm/wcm-9999.ebuild')
-rw-r--r--gui-apps/wcm/wcm-9999.ebuild34
1 files changed, 26 insertions, 8 deletions
diff --git a/gui-apps/wcm/wcm-9999.ebuild b/gui-apps/wcm/wcm-9999.ebuild
index d91c7aa57b64..20dc340547dc 100644
--- a/gui-apps/wcm/wcm-9999.ebuild
+++ b/gui-apps/wcm/wcm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2023 Gentoo Authors
+# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -11,24 +11,42 @@ HOMEPAGE="https://github.com/WayfireWM/wcm"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/WayfireWM/wcm.git"
+ SLOT="0/9999"
else
SRC_URI="https://github.com/WayfireWM/wcm/releases/download/v${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm64 ~x86"
+ SLOT="0/$(ver_cut 1-2)"
fi
LICENSE="MIT"
-SLOT="0"
-DEPEND="
+RESTRIC="test" # no tests
+
+CDEPEND="
dev-libs/libevdev
dev-libs/libxml2
+ dev-libs/wayland
dev-cpp/gtkmm:3.0[wayland]
- >=gui-wm/wayfire-${PV%.*}
+ gui-apps/wf-shell:${SLOT}
+ gui-libs/wf-config:${SLOT}
+ gui-wm/wayfire:${SLOT}
+ x11-libs/libxkbcommon
"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="
+RDEPEND="${CDEPEND}"
+DEPEND="
+ ${CDEPEND}
dev-libs/wayland-protocols
+"
+BDEPEND="
+ dev-util/wayland-scanner
virtual/pkgconfig
"
+
+src_configure() {
+ local emesonargs=(
+ -Dwf_shell=enabled
+ -Denable_wdisplays=true
+ )
+
+ meson_src_configure
+}