summaryrefslogtreecommitdiff
path: root/gui-apps/swaylock/swaylock-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/swaylock/swaylock-1.5-r1.ebuild')
-rw-r--r--gui-apps/swaylock/swaylock-1.5-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/gui-apps/swaylock/swaylock-1.5-r1.ebuild b/gui-apps/swaylock/swaylock-1.5-r1.ebuild
new file mode 100644
index 000000000000..c3e2e1fccdce
--- /dev/null
+++ b/gui-apps/swaylock/swaylock-1.5-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit fcaps meson
+
+DESCRIPTION="Screen locker for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaylock"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="+gdk-pixbuf +man +pam"
+
+DEPEND="
+ dev-libs/wayland
+ x11-libs/cairo
+ x11-libs/libxkbcommon
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf:2 )
+ pam? ( sys-libs/pam )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dpam=$(usex pam enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
+ "-Dbash-completions=true"
+ "-Dwerror=false"
+ )
+
+ if [[ ${PV} != 9999 ]]; then
+ emesonargs+=( "-Dswaylock-version=${PV}" )
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ if ! use pam; then
+ fcaps cap_sys_admin usr/bin/swaylock
+ fi
+}