summaryrefslogtreecommitdiff
path: root/gui-apps/swayidle/swayidle-1.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/swayidle/swayidle-1.6.ebuild')
-rw-r--r--gui-apps/swayidle/swayidle-1.6.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/gui-apps/swayidle/swayidle-1.6.ebuild b/gui-apps/swayidle/swayidle-1.6.ebuild
index ae2ed9985b48..94194af2e4ae 100644
--- a/gui-apps/swayidle/swayidle-1.6.ebuild
+++ b/gui-apps/swayidle/swayidle-1.6.ebuild
@@ -18,7 +18,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="elogind fish-completion +man systemd zsh-completion"
+IUSE="elogind +man systemd"
REQUIRED_USE="?? ( elogind systemd )"
DEPEND="
@@ -36,11 +36,12 @@ BDEPEND="
src_configure() {
local emesonargs=(
-Dman-pages=$(usex man enabled disabled)
- $(meson_use fish-completion fish-completions)
- $(meson_use zsh-completion zsh-completions)
+ "-Dfish-completions=true"
+ "-Dzsh-completions=true"
"-Dbash-completions=true"
"-Dwerror=false"
)
+
if use systemd; then
emesonargs+=("-Dlogind=enabled" "-Dlogind-provider=systemd")
elif use elogind; then