summaryrefslogtreecommitdiff
path: root/gui-apps/mako/mako-1.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/mako/mako-1.6-r3.ebuild')
-rw-r--r--gui-apps/mako/mako-1.6-r3.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/gui-apps/mako/mako-1.6-r3.ebuild b/gui-apps/mako/mako-1.6-r3.ebuild
deleted file mode 100644
index a5b496449431..000000000000
--- a/gui-apps/mako/mako-1.6-r3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A lightweight notification daemon for Wayland. Works on Sway"
-HOMEPAGE="https://github.com/emersion/mako"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/emersion/${PN}.git"
-else
- SRC_URI="https://github.com/emersion/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="elogind +icons systemd"
-
-DEPEND="
- dev-libs/wayland
- x11-libs/pango
- x11-libs/cairo
- || (
- systemd? ( sys-apps/systemd )
- elogind? ( sys-auth/elogind )
- sys-libs/basu
- )
- sys-apps/dbus
- icons? (
- x11-libs/gtk+:3
- x11-libs/gdk-pixbuf
- )
-"
-RDEPEND="
- ${DEPEND}
- >=dev-libs/wayland-protocols-1.21
-"
-BDEPEND="
- virtual/pkgconfig
- app-text/scdoc
-"
-
-src_configure() {
- local emesonargs=(
- -Dicons=$(usex icons enabled disabled)
- )
-
- if use systemd ; then
- emesonargs+=( -Dsd-bus-provider=libsystemd )
- elif use elogind ; then
- emesonargs+=( -Dsd-bus-provider=libelogind )
- else
- emesonargs+=( -Dsd-bus-provider=basu )
- fi
-
- meson_src_configure
-}