summaryrefslogtreecommitdiff
path: root/gui-apps/kanshi/kanshi-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/kanshi/kanshi-1.1.0.ebuild')
-rw-r--r--gui-apps/kanshi/kanshi-1.1.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/gui-apps/kanshi/kanshi-1.1.0.ebuild b/gui-apps/kanshi/kanshi-1.1.0.ebuild
deleted file mode 100644
index 521c47e33cb0..000000000000
--- a/gui-apps/kanshi/kanshi-1.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="dynamic display configuration (autorandr for wayland)"
-HOMEPAGE="https://github.com/emersion/kanshi"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/emersion/kanshi"
-else
- SRC_URI="https://github.com/emersion/kanshi/releases/download/v${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="+man"
-
-RDEPEND="
- dev-libs/wayland
-"
-BDEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- dev-libs/wayland-protocols
-"
-
-if [[ ${PV} == 9999 ]]; then
- BDEPEND+="man? ( ~app-text/scdoc-9999 )"
-else
- BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
-fi
-
-src_configure() {
- local emesonargs=(
- $(meson_feature man man-pages)
- )
- meson_src_configure
-}