summaryrefslogtreecommitdiff
path: root/gui-apps/gnome-console/gnome-console-45.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gui-apps/gnome-console/gnome-console-45.0-r1.ebuild')
-rw-r--r--gui-apps/gnome-console/gnome-console-45.0-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/gui-apps/gnome-console/gnome-console-45.0-r1.ebuild b/gui-apps/gnome-console/gnome-console-45.0-r1.ebuild
new file mode 100644
index 000000000000..0493159dd6f9
--- /dev/null
+++ b/gui-apps/gnome-console/gnome-console-45.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple user-friendly terminal emulator for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/console"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.76:2
+ >=gui-libs/gtk-4.12.2:4
+ >=gui-libs/libadwaita-1.4_alpha:1
+ >=gui-libs/vte-0.70.0:2.91-gtk4
+ gnome-base/libgtop:2=
+ >=dev-libs/libpcre2-10.32:0=
+ gnome-base/gsettings-desktop-schemas
+
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddevel=false
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}