summaryrefslogtreecommitdiff
path: root/gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild')
-rw-r--r--gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild b/gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild
index c03c159ce0b4..fdf837fd0ec1 100644
--- a/gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild
+++ b/gnustep-base/gnustep-updater/gnustep-updater-0.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,13 @@ RDEPEND="app-misc/pax-utils
>=gnustep-base/gnustep-make-2.6.0"
DEPEND="${RDEPEND}"
+src_prepare() {
+ default
+
+ sed -e "s#/etc/init.d/functions.sh#/lib/gentoo/functions.sh#" \
+ -i gnustep-updater || die
+}
+
src_install() {
dosbin gnustep-updater
doman gnustep-updater.1