summaryrefslogtreecommitdiff
path: root/gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild')
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild
index 4b7effe4b8ff..9380d0784295 100644
--- a/gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.28.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit gnustep-base multilib
+inherit gnustep-base multilib virtualx
DESCRIPTION="Library of GUI classes written in Obj-C"
HOMEPAGE="http://www.gnustep.org/"
@@ -10,7 +10,7 @@ SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+KEYWORDS="~alpha amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="cups gif icu jpeg png speech"
DEPEND="${GNUSTEP_CORE_DEPEND}
@@ -55,3 +55,7 @@ src_configure() {
--with-tiff-library="${EPREFIX}"/usr/$(get_libdir) \
${myconf}
}
+
+src_test() {
+ virtx default
+}