summaryrefslogtreecommitdiff
path: root/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild
new file mode 100644
index 000000000000..60096b115e4c
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.30.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnustep-base
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
+HOMEPAGE="https://gnustep.github.io"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+S="${WORKDIR}/gnustep-back-${PV}"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="opengl xim"
+
+RDEPEND="${GNUSTEP_CORE_DEPEND}
+ =gnustep-base/gnustep-gui-${PV%.*}*
+ >=media-libs/freetype-2.1.9
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ opengl? ( virtual/opengl virtual/glu )
+
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-cairo"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # do not compress man pages
+ sed -i '/which gzip/,/&& gzip/d' Tools/GNUmakefile.postamble || die
+}
+
+src_configure() {
+ egnustep_env
+
+ myconf="$(use_enable opengl glx)"
+ myconf="$myconf $(use_enable xim)"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib"
+
+ econf $myconf
+}