summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-weather
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest2
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-40.1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index ce6e65c6df3b..547fdf3d9510 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1,3 +1,5 @@
DIST gnome-weather-40.0.tar.xz 938732 BLAKE2B bc46da61e9620278f5abc7964b869520da85837739923618b2ade114c8561fc6125e7dca2f2aef5715fec7dfa0561c693f75278d050900cb948f8d1ea42f58ba SHA512 c4560c1a1535a0c2889c8cd934926217a7caceb1b646fa4bb961c7cbde38b9b545a567f24fb81e47c61a2ac3e456a5432e8979591eb5a169fe5849bbd99d6333
+DIST gnome-weather-40.1.tar.xz 941636 BLAKE2B 110b972eb3eb6319632d00592f9bf50220bb6976bb27f814606758fd6ce98ad9dfdfabcb0e2d4a68f8005aa3cb92538e4820c8add8f7f8cb94a96f7df9453cf8 SHA512 47086225a2f0212665e53f053d46b54792d4daebff841bb751a7ed8ca7e2e1d60f0247d890011a03cab4104b0461b71316ff9b6eaea671c68bc1713c38e447dc
EBUILD gnome-weather-40.0.ebuild 1371 BLAKE2B e602d5fd95238b9a88deaf4ce43e3f9de71c76042dce1e6345970549e0de1b68565d96dc637090253e1f83794b65778d30599306d273c5d4e3c2526092e0d306 SHA512 9777853eca87d926a23c0456b04e36e6b264cb4879a999520ebd1076e839a88532011cc2a8b1a2870b503f7014f20c2f8fb955d63e0a7a328f05edd11dfc7e85
+EBUILD gnome-weather-40.1.ebuild 1373 BLAKE2B 2b6f0eda96f706c54f16a656f8e554f35f69393ddced7f92fd7dcb225e8153fbe9e905d53271f879edd5e8947168a85d1891050cf8a748c19f326ee79ad5378f SHA512 55b4f742f13e4c4eaa4793ce860348fe1807bfec38a90ad683192d15e7255903da17af9852b53c49b7cd8e7c073781b51eda80d1b51925fe91c923ef56998acd
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild b/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild
new file mode 100644
index 000000000000..ddc78bc521b6
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-40.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-40.0:=
+ >=gui-libs/libhandy-1.1.90:1=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}