summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild')
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
index fc0744aeb705..9b3b4d59ea7a 100644
--- a/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-40.0.ebuild
@@ -4,9 +4,9 @@
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit gnome.org meson python-single-r1 xdg
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
-DESCRIPTION="Customize advanced GNOME 3 options"
+DESCRIPTION="Customize advanced GNOME options"
HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
LICENSE="GPL-3+ CC0-1.0"
@@ -28,7 +28,7 @@ RDEPEND="${DEPEND}
>=dev-libs/glib-2.58:2
>=x11-libs/gtk+-3.12:3[introspection]
>=gnome-base/gnome-desktop-3.30:3[introspection]
- gui-libs/libhandy:0.0[introspection]
+ gui-libs/libhandy:1[introspection]
net-libs/libsoup:2.4[introspection]
x11-libs/libnotify[introspection]
@@ -47,3 +47,13 @@ src_install() {
python_optimize
python_fix_shebang "${ED}"/usr/bin/
}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}