summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen')
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest2
-rw-r--r--gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
index 9c98d7cd853c..35828daacd97 100644
--- a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/Manifest
@@ -1,3 +1,5 @@
DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.tar.gz 14863 BLAKE2B 11133a5bf6ea06acd2fce6f215fcc6a37a658857161b9babab51246d6d7d382773e92f395796410fafa903ace656aa664c749a501bcbd4d05ebbd81ea9fd5018 SHA512 06f6329a6a2b2e03cacd305e1dad81768b81d6193782739caeadc51f141da9238d2bff563276235673e492ad7f13977fe7f1eaba73ca940a410b94defbeae5b0
+DIST gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.tar.gz 2592 BLAKE2B 205309c4057094301e3469471b0f2da06a6cdf6f36b430b636f5341acde98ae999a537ca3a815a257fd9e3abde8f30bffb9a78f38926224eea3ec29d92548f2b SHA512 d314227588dac2f51b1d6946bac29501607b3e4fa6c3394b4bf56576453d6e6aa5a76fb2b576e216d5e62dabd8994418f11838d95bd90f134d261223fab04dd8
EBUILD gnome-shell-extension-control-blur-effect-on-lock-screen-20210614.ebuild 1338 BLAKE2B 1a24cb39abe74cc8fb7a7681e327f62bafd8db533e854834d804baa7435c90ab15892d71fa21694fa22d8854edf0c9913357fb103d9f420f1055af477ea64d2c SHA512 d8ad8ff5ee49f55ec35ee425030dcd43a02c2c67a61a2367b46ee030c10ce8eacfb68440e03536c80250ba82d912ee32d669df7c6a17b4472ec3d42eb57dce68
+EBUILD gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.ebuild 1322 BLAKE2B de49e1f79be1d78eaefd37c710c219493d7ce995526af0ffbcbda9eaea6a92f008a4622ff4207cf8513d716762ea44ee059a836f78891ad217ee2423f60ec207 SHA512 c7a01133b35c7f7e0a9fa6bd5113d4b88230826468cd4dfa4960028a6b144e96883fa195a05af10834a6f620a074b763c2bd1ce8916b05bef4f103d949e39147
MISC metadata.xml 240 BLAKE2B 63b29b3fa5f9613689cca20017685c7b8fda461b37bd79b15deb70b8691afdbb1a262dac93cb3520a9d9e9c49ba745f8c797b269bb41933391a5a94667bb1c24 SHA512 2d1e63e0f72d6332021e3c9bdacb1e2b203a31b907c5a93c305e4f7b0eeef0856fb0cca37bc0d7d3d1ba77b08f81c7626f834239e3484e13032cedf59304239e
diff --git a/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.ebuild b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.ebuild
new file mode 100644
index 000000000000..65e9829e48ef
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen/gnome-shell-extension-control-blur-effect-on-lock-screen-20210721.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome2-utils
+
+DESCRIPTION="Control the blur effect on gnome-shell lock screen"
+HOMEPAGE="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen"
+COMMIT="1dc40c2a9e3bfdf851c7726b041484c8663b28e9"
+SRC_URI="https://github.com/PRATAP-KUMAR/Control_Blur_Effect_On_Lock_Screen/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# glib for glib-compile-schemas at build time, needed at runtime anyways
+COMMON_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="${COMMON_DEPEND}
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND="${COMMON_DEPEND}"
+BDEPEND=""
+
+extension_uuid="ControlBlurEffectOnLockScreen@pratap.fastmail.fm"
+S="${WORKDIR}/Control_Blur_Effect_On_Lock_Screen-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf LICENSE README.md schemas
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}