summaryrefslogtreecommitdiff
path: root/gnome-extra/gnome-contacts
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gnome-contacts')
-rw-r--r--gnome-extra/gnome-contacts/Manifest5
-rw-r--r--gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch29
-rw-r--r--gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch50
-rw-r--r--gnome-extra/gnome-contacts/gnome-contacts-3.22.1-r1.ebuild75
-rw-r--r--gnome-extra/gnome-contacts/metadata.xml8
5 files changed, 167 insertions, 0 deletions
diff --git a/gnome-extra/gnome-contacts/Manifest b/gnome-extra/gnome-contacts/Manifest
new file mode 100644
index 000000000000..f33285beaf7f
--- /dev/null
+++ b/gnome-extra/gnome-contacts/Manifest
@@ -0,0 +1,5 @@
+AUX 3.22.1-fix-vala-0.35-part1.patch 884 BLAKE2B 2994fc2b28bbe8f3b547542b100324fce5d95b385ea8edc1013c86c1e0df1dabafb4306b8153953c67a36e1d96e1c658c599afea5f1c3e3a7d617d01c05d3224 SHA512 73754d230efe89d3e3273e1d24a69e58e45a8d6e74fce1a41f7a7889aa58189fcc2f5edf36ce2418c43871716634301308f0c211f0f18282cb409d009669bdf2
+AUX 3.22.1-fix-vala-0.35-part2.patch 1501 BLAKE2B ca7149152cae32912977bb8a2ca420d1711fcff5e2b18e040d9969e246a0398f66ad09cee72f22b282d6eec834d10721a99d270ba873d782f09bc6e30b7c80d6 SHA512 700772e2c87bfad32e408f20653a20976c0a3b243fd4bc8b6ed61cb9fe34f1b1f572b877aa05e9b9c3854cc444d5d7fc1c26dcd9ac28bf76694eb02c2e31bb4c
+DIST gnome-contacts-3.22.1.tar.xz 788820 BLAKE2B 8f620334dd380e8cb690f7b71d3a99a921f5814ab230690a60be6022150db7a6a0f74e426e72d8d027eb5280e1b6bfd04fa7b0b030519bb19e4718ca0c9f2120 SHA512 d93ed6c65ffdabe1925cc795b88ff374fe69e03fcd36af7c2fc67a5236b90ab6af4bd269b6fc3b344fcd6b4688d866628b8b090bb62de95f8bd0c2e40c26a107
+EBUILD gnome-contacts-3.22.1-r1.ebuild 1840 BLAKE2B 3678c0ff5796cb2bfed0d35954e0553bdb6b94c79fd9e4d120fac3a307351c948c4cf2d733878002907af6416548ef6c18063fce60a48b022e3f0faa9130e6d2 SHA512 81cfe1119ad2b63bb3041eecae2b4a5b0dc0e1b8e4901f6ad74cb1c52004abcd820dd131f3b2bac0e0d7b067c69c2a53a84187ab7f9019d991f81de79def191d
+MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch
new file mode 100644
index 000000000000..b9634e6fc041
--- /dev/null
+++ b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part1.patch
@@ -0,0 +1,29 @@
+From 2ba6e380dd8a3575bd8f4d4e5d8d3883003e9f54 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sat, 1 Oct 2016 14:27:55 +0200
+Subject: [PATCH] Don't restrict RowData.details to the generic type "string"
+
+This allows AbstractFieldDetails<G> based values to be assigned,
+like PostalAddressFieldDetails.
+
+Fixes a build-failure with vala 0.35+ due to stricter type-checking.
+---
+ src/contacts-contact-editor.vala | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/contacts-contact-editor.vala b/src/contacts-contact-editor.vala
+index 3372f87..3978887 100644
+--- a/src/contacts-contact-editor.vala
++++ b/src/contacts-contact-editor.vala
+@@ -77,7 +77,7 @@ public class Contacts.ContactEditor : Grid {
+ }
+
+ struct RowData {
+- AbstractFieldDetails<string> details;
++ AbstractFieldDetails details;
+ }
+
+ struct Field {
+--
+2.14.1
+
diff --git a/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch
new file mode 100644
index 000000000000..4cfe861fa509
--- /dev/null
+++ b/gnome-extra/gnome-contacts/files/3.22.1-fix-vala-0.35-part2.patch
@@ -0,0 +1,50 @@
+From b96b0fc07c49724f252a5cd35f2d028f91529068 Mon Sep 17 00:00:00 2001
+From: Jeena <hello@jeena.net>
+Date: Tue, 15 Aug 2017 16:53:05 +0200
+Subject: [PATCH] Drop unnecessary format-string.
+
+Code got refactored in 3.25/master but it boils down to dropping this
+extra parameter.
+---
+ src/contacts-contact-pane.vala | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/src/contacts-contact-pane.vala b/src/contacts-contact-pane.vala
+index 8e100f2..fce832b 100644
+--- a/src/contacts-contact-pane.vala
++++ b/src/contacts-contact-pane.vala
+@@ -451,7 +451,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("You need to enter some data"));
+ dialog.show ();
+ dialog.response.connect ( () => {
+@@ -463,7 +462,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("No primary addressbook configured"));
+ dialog.show ();
+ dialog.response.connect ( () => {
+@@ -482,7 +480,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("Unable to create new contacts: %s"), e.message);
+ }
+
+@@ -493,7 +490,6 @@ public class Contacts.ContactPane : Notebook {
+ DialogFlags.MODAL,
+ MessageType.ERROR,
+ ButtonsType.OK,
+- "%s",
+ _("Unable to find newly created contact"));
+ }
+
+--
+2.14.1
+
diff --git a/gnome-extra/gnome-contacts/gnome-contacts-3.22.1-r1.ebuild b/gnome-extra/gnome-contacts/gnome-contacts-3.22.1-r1.ebuild
new file mode 100644
index 000000000000..95083e15f4ef
--- /dev/null
+++ b/gnome-extra/gnome-contacts/gnome-contacts-3.22.1-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_USE_DEPEND="vapigen"
+VALA_MIN_API_VERSION="0.24"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME contact management application"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Contacts"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="v4l"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+VALA_DEPEND="
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-0.9.6:=
+ dev-libs/folks[vala(+)]
+ gnome-base/gnome-desktop:3=[introspection]
+ gnome-extra/evolution-data-server[vala]
+ net-libs/telepathy-glib[vala]
+"
+# Configure is wrong; it needs cheese-3.5.91, not 3.3.91
+# folks-0.11.4 to avoid build issues with vala-0.36, upstream 7a9001b056b4fb1d00375e7b2adeda9b7cf93c90
+RDEPEND="
+ >=dev-libs/folks-0.11.4:=[eds,telepathy]
+ >=dev-libs/glib-2.37.6:2
+ >=dev-libs/libgee-0.10:0.8
+ >=gnome-extra/evolution-data-server-3.13.90:=[gnome-online-accounts]
+ >=gnome-base/gnome-desktop-3.0:3=
+ media-libs/clutter:1.0
+ media-libs/clutter-gtk:1.0
+ media-libs/libchamplain:0.12
+ net-libs/gnome-online-accounts:=
+ >=net-libs/telepathy-glib-0.17.5
+ >=sci-geosciences/geocode-glib-3.15.3
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.20.0:3
+ x11-libs/pango
+ v4l? ( >=media-video/cheese-3.5.91:= )
+"
+DEPEND="${RDEPEND}
+ ${VALA_DEPEND}
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-fix-vala-0.35-part1.patch
+ "${FILESDIR}"/${PV}-fix-vala-0.35-part2.patch
+)
+
+src_prepare() {
+ # Regenerate the pre-generated C sources, bug #471628
+ if ! use v4l; then
+ touch src/*.vala
+ fi
+
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-man-pages \
+ $(use_with v4l cheese)
+}
diff --git a/gnome-extra/gnome-contacts/metadata.xml b/gnome-extra/gnome-contacts/metadata.xml
new file mode 100644
index 000000000000..39980802b1da
--- /dev/null
+++ b/gnome-extra/gnome-contacts/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+</pkgmetadata>