summaryrefslogtreecommitdiff
path: root/gnome-extra/eiciel/eiciel-0.9.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/eiciel/eiciel-0.9.13.1.ebuild')
-rw-r--r--gnome-extra/eiciel/eiciel-0.9.13.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnome-extra/eiciel/eiciel-0.9.13.1.ebuild b/gnome-extra/eiciel/eiciel-0.9.13.1.ebuild
new file mode 100644
index 000000000000..5ea9779a81fb
--- /dev/null
+++ b/gnome-extra/eiciel/eiciel-0.9.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2
+
+DESCRIPTION="ACL editor for GNOME, with Nautilus extension"
+HOMEPAGE="https://rofi.roger-ferrer.org/eiciel/"
+SRC_URI="https://rofi.roger-ferrer.org/eiciel/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nautilus xattr"
+
+DEPEND="
+ >=sys-apps/acl-2.2.32
+ dev-cpp/gtkmm:3.0
+ >=dev-cpp/glibmm-2.50:2
+ nautilus? ( >=gnome-base/nautilus-3 )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.18.1
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --with-gnome-version=3 \
+ $(use_enable nautilus nautilus-extension) \
+ $(use_enable xattr user-attributes)
+}