summaryrefslogtreecommitdiff
path: root/gnome-extra/cjs
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/cjs')
-rw-r--r--gnome-extra/cjs/Manifest2
-rw-r--r--gnome-extra/cjs/cjs-6.0.0.ebuild91
2 files changed, 0 insertions, 93 deletions
diff --git a/gnome-extra/cjs/Manifest b/gnome-extra/cjs/Manifest
index 7c352ff7c4cb..1be302677a88 100644
--- a/gnome-extra/cjs/Manifest
+++ b/gnome-extra/cjs/Manifest
@@ -1,5 +1,3 @@
-DIST cjs-6.0.0.tar.gz 877404 BLAKE2B 4290f0801f715aab1387da2ce0724376912db8ff3ad16fa8ad7eff03538dfc53ecbff2b7df0e70e52d16295b23ce51024da735d0e618b995fd3d3dfe297f9e26 SHA512 4cb359bf817d22a727683fd451ad6bde19aff4409e9033a97ef9cb204b3bd4c5e86421d7c01a267c3b4d42feb9b3bc5effb6fd970b3baf733242868c09536d95
DIST cjs-6.2.0.tar.gz 874457 BLAKE2B 7b1afda55bc0b5da165a20afa7be58382b8f03f1421bde960f6a3f134d7bdb2bdd44320b0b613f4f710258379da6666383a20d92556a1172971ca8340ae6d348 SHA512 5f7ce7f1ba648db834d7703e909ef65cf369d47147ca02e90b8844c31b4360dcc0fb94bbd3265632c3de8ef2b026934dd799b94a2ff3895442a2f9fc469f53db
-EBUILD cjs-6.0.0.ebuild 2308 BLAKE2B 09e1ccb3f292bf706ce59d9360225e398f96a8fd0fa0a2be2bd1334e4a4bd88903f4bbfb4163f3931c62bae46800c77d2cbfa3ebe3aaa042f4210ca24d5e55d6 SHA512 15850b794b84057e27227bb4dd95c4555a5896d2cd684308e9e331e8acaa1703892eeb5d7465d78291c11cbb88d61eb9058532265fa7bc7a75b283478815cb94
EBUILD cjs-6.2.0.ebuild 2308 BLAKE2B a4b05f2b53a94f82b8de9791507ef73683eafb80ef3c077383ffad30a6efaa8e3eba929c7c83cacb2b52ab2d2e2a2a79d397cafb2610e485fc4482e11413b84f SHA512 bb7113c9118526e4a240038efa0294ad8255c6e88a0966fff8c314943cfd4b1db9ef5eea38a87f9d79d9185eeba2453613831d2b6bee9a7d6af47b209be0fd6c
MISC metadata.xml 608 BLAKE2B 7cc55145357fc7b4b46e1a77f19570b60f5dc6207c81efc3b92adf7d5fdb025296d4e6b8b927f193ed7bd0a929274e61c9bdddad2371ca78a497b94fdbe87737 SHA512 672923005e936fd3d08367a8db65318f63217841e6f841623d469c21ce354724f6c2cea853ecca928280b21011d6aa0e133a7830841c9fa44dd8c36402b28066
diff --git a/gnome-extra/cjs/cjs-6.0.0.ebuild b/gnome-extra/cjs/cjs-6.0.0.ebuild
deleted file mode 100644
index 73c12443341d..000000000000
--- a/gnome-extra/cjs/cjs-6.0.0.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit flag-o-matic meson pax-utils python-any-r1 virtualx
-
-DESCRIPTION="Linux Mint's fork of gjs for Cinnamon"
-HOMEPAGE="https://projects.linuxmint.com/cinnamon/ https://github.com/linuxmint/cjs"
-SRC_URI="https://github.com/linuxmint/cjs/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD CC0-1.0 MIT MPL-2.0 || ( MPL-1.1 GPL-2+ LGPL-2.1+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="amd64 ~arm64 ~loong ~ppc64 ~riscv x86"
-
-RDEPEND="
- dev-lang/spidermonkey:102
- >=dev-libs/glib-2.66.0:2
- >=dev-libs/gobject-introspection-1.71.0:=
- >=dev-libs/libffi-3.3:0=
-
- cairo? (
- x11-libs/cairo[glib,svg(+),X]
- x11-libs/libX11
- )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="
- ${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- x11-libs/gtk+:3[introspection]
- )
-"
-BDEPEND="
- ${PYTHON_DEPS}
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- python_fix_shebang build
-}
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}
-
-src_install() {
- meson_src_install
-
- if use examples; then
- docinto examples
- dodoc "${S}"/examples/*
- fi
-
- # Required for cjs-console to run correctly on PaX systems
- pax-mark mr "${ED}/usr/bin/cjs-console"
-}