summaryrefslogtreecommitdiff
path: root/gnome-base
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/Manifest.gzbin4723 -> 4720 bytes
-rw-r--r--gnome-base/gdm/Manifest1
-rw-r--r--gnome-base/gdm/gdm-46.2-r2.ebuild220
-rw-r--r--gnome-base/gnome-shell/Manifest2
-rw-r--r--gnome-base/gnome-shell/gnome-shell-46.7.ebuild188
5 files changed, 411 insertions, 0 deletions
diff --git a/gnome-base/Manifest.gz b/gnome-base/Manifest.gz
index 230a426578a6..c3aba3dcb6df 100644
--- a/gnome-base/Manifest.gz
+++ b/gnome-base/Manifest.gz
Binary files differ
diff --git a/gnome-base/gdm/Manifest b/gnome-base/gdm/Manifest
index be91827e52d1..565e48ccf5fb 100644
--- a/gnome-base/gdm/Manifest
+++ b/gnome-base/gdm/Manifest
@@ -6,4 +6,5 @@ DIST gdm-46.2.tar.xz 931868 BLAKE2B 53b6efb6ae0a60592c6790c4ff676e6bdd7e8096eabb
DIST tango-gentoo-v1.1.tar.gz 29322 BLAKE2B 83fa2bf37727e60851dd679054fe1b153ebfea58c9a9a40f891f7d68d3b047b02e8effa1d1b4e08d64500a2072ce7200f159c92a352da7124de27e1b05bb6027 SHA512 87d47ddab68361db6d99866c51705dcb3e198f8345a1096859acf2c6cca5099dd23c7fb30d124f52c4933ea38fd45fadffbbe6ecbdfa84f5b60938a4824f9045
EBUILD gdm-45.0.1-r2.ebuild 5813 BLAKE2B d9c32f5bbb3bb34c7c917e6d6145514953f75c78aaae7780179daeec096cf93dbcae873a18e26859b32f055c86277e54d2fef735d470afc8611315653d1d43bc SHA512 bbd0f006a767ccc517a73925cc38717bfff5e717668efc79a3224d4d834d83639bd3a5a091028d7a692ee2555148302448956b679984444a9ed73ebd7f89eacf
EBUILD gdm-46.2-r1.ebuild 5741 BLAKE2B afcf4555f4d4d16561375cb9482a3fd309c633420e49834f6ad9c4b738ea6db9291bbf44334356e6595e111306643888ea65265dbc660885b8ed2ff06ebfc1a3 SHA512 4dfebfddad2422ad1ceabf441862a00d42212f06f38fe5f035f35e0c24a9259a9f54a57bd6f4ddf7f9d2ffeebcf9e220ad7cd80bc69716a1979a48db1ae6faa9
+EBUILD gdm-46.2-r2.ebuild 5785 BLAKE2B 640f54690ccf1edc59ea7d0b7bb3ce1e532d97f280ff89ca7ef8e2dd4a845224886cddc044eebc1a475b42f94e1cda733b5ae958ad31f0bc0525d4980c8cb785 SHA512 2c241ff82ebe4465984b9f85045dac3ee3cee3ba5f882922250d27e126701cc6a2787efb3857158af0efee8ab11a43f29fad963cd61ad8c19d76f3b3beff7d4e
MISC metadata.xml 775 BLAKE2B c5e6f026d1a42133c98e450ac82e943485e81d42ead7e632d9c8610442d5a138393bb1c0e97827f2b450719ba0450471eff7d04908429acd63818cbea6f49144 SHA512 562bea1d24550c5de69a15102f259e05498f1bd6b7d2a40bd4997546dd373e9fe9911a7873ee3b3c16c149f891766eb5bdfbefa3aa6589f9c8425f7d3b65ced0
diff --git a/gnome-base/gdm/gdm-46.2-r2.ebuild b/gnome-base/gdm/gdm-46.2-r2.ebuild
new file mode 100644
index 000000000000..ede649e83d4a
--- /dev/null
+++ b/gnome-base/gdm/gdm-46.2-r2.ebuild
@@ -0,0 +1,220 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop flag-o-matic gnome.org gnome2-utils meson pam readme.gentoo-r1 systemd udev xdg
+
+DESCRIPTION="GNOME Display Manager for managing graphical display servers and user logins"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gdm"
+
+SRC_URI="${SRC_URI}
+ branding? ( https://www.mail-archive.com/tango-artists@lists.freedesktop.org/msg00043/tango-gentoo-v1.1.tar.gz )
+"
+
+LICENSE="
+ GPL-2+
+ branding? ( CC-BY-SA-4.0 )
+"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+IUSE="accessibility audit bluetooth-sound branding elogind fprint plymouth selinux systemd tcpd test wayland"
+
+RESTRICT="!test? ( test )"
+REQUIRED_USE="^^ ( elogind systemd )"
+
+# dconf, dbus and g-s-d are needed at install time for dconf update
+# keyutils is automagic dep that makes autologin unlock login keyring
+# when all the passwords match (disk encryption, user pw and login keyring)
+# dbus-run-session used at runtime
+COMMON_DEPEND="
+ virtual/udev
+ >=dev-libs/libgudev-232:=
+ >=dev-libs/glib-2.68:2
+ >=x11-libs/gtk+-2.91.1:3
+ >=dev-libs/json-glib-1.2.0
+ || (
+ media-libs/libcanberra-gtk3
+ >=media-libs/libcanberra-0.4[gtk3(-)]
+ )
+ >=sys-apps/accountsservice-0.6.35
+ x11-libs/libxcb
+ sys-apps/keyutils:=
+ selinux? ( sys-libs/libselinux )
+
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-base/xorg-server[-minimal]
+ x11-libs/libXdmcp
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+
+ systemd? ( >=sys-apps/systemd-186:0=[pam] )
+ elogind? ( >=sys-auth/elogind-239.3[pam] )
+
+ plymouth? ( sys-boot/plymouth )
+ audit? ( sys-process/audit )
+
+ sys-libs/pam
+ sys-auth/pambase[elogind?,systemd?]
+
+ >=gnome-base/dconf-0.20
+ >=gnome-base/gnome-settings-daemon-3.1.4
+ gnome-base/gsettings-desktop-schemas
+ sys-apps/dbus
+
+ >=x11-misc/xdg-utils-1.0.2-r3
+
+ >=dev-libs/gobject-introspection-0.9.12:=
+"
+# XXX: These deps are from session and desktop files in data/ directory
+# fprintd is used via dbus by gdm-fingerprint-extension
+RDEPEND="${COMMON_DEPEND}
+ acct-group/gdm
+ acct-user/gdm
+ >=gnome-base/gnome-session-3.6
+ >=gnome-base/gnome-shell-3.1.90
+ x11-apps/xhost
+
+ accessibility? (
+ >=app-accessibility/orca-3.10
+ gnome-extra/mousetweaks
+ )
+ fprint? ( sys-auth/fprintd[pam] )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=gnome-base/dconf-0.20
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( >=dev-libs/check-0.9.4 )
+"
+
+DOC_CONTENTS="
+ To start GDM at boot with systemd, run:\n
+ # systemctl enable gdm.service\n
+ \n
+ To start GDM at boot with OpenRC, set DISPLAYMANAGER=\"gdm\"\n
+ in /etc/conf.d/display-manager and enable the display-manager service:\n
+ # rc-update add display-manager\n
+ \n
+ For passwordless login to unlock your keyring, you need to install
+ sys-auth/pambase with USE=gnome-keyring and set an empty password
+ on your keyring. Use app-crypt/seahorse for that.\n
+ \n
+ You may need to install app-crypt/coolkey and sys-auth/pam_pkcs11
+ for smartcard support
+"
+
+src_prepare() {
+ default
+
+ # Show logo when branding is enabled
+ use branding && eapply "${FILESDIR}/${PN}-3.30.3-logo.patch"
+}
+
+src_configure() {
+ # bug #944223
+ append-cflags -std=gnu17
+
+ # --with-initial-vt=7 conflicts with plymouth, bug #453392
+ # gdm-3.30 now reaps (stops) the login screen when the login VT isn't active, which
+ # saves on memory. However this means if we don't start on VT1, gdm doesn't start up
+ # before user manually goes to VT7. Thus as-is we can not keep gdm away from VT1,
+ # so lets try always having it in VT1 and see if that is an issue for people before
+ # hacking up workarounds for the initial start case.
+ local emesonargs=(
+ --localstatedir /var
+
+ -Ddefault-pam-config=exherbo
+ -Dgdm-xsession=true
+ -Dgroup=gdm
+ -Dipv6=true
+ $(meson_feature audit libaudit)
+ -Dlogind-provider=$(usex systemd systemd elogind)
+ -Dpam-mod-dir=$(getpam_mod_dir)
+ $(meson_feature plymouth)
+ -Drun-dir=/run/gdm
+ $(meson_feature selinux)
+ $(meson_use systemd systemd-journal)
+ $(meson_use tcpd tcp-wrappers)
+ -Dudev-dir=$(get_udevdir)/rules.d
+ -Duser=gdm
+ -Duser-display-server=true
+ $(meson_use wayland wayland-support)
+ -Dxdmcp=enabled
+ )
+
+ if use elogind; then
+ emesonargs+=(
+ -Dinitial-vt=7 # TODO: Revisit together with startDM.sh and other xinit talks; also ignores plymouth possibility
+ -Dsystemdsystemunitdir=no
+ -Dsystemduserunitdir=no
+ )
+ else
+ emesonargs+=(
+ -Dinitial-vt=1
+ -Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
+ -Dsystemduserunitdir="$(systemd_get_userunitdir)"
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use accessibility ; then
+ rm "${ED}"/usr/share/gdm/greeter/autostart/orca-autostart.desktop || die
+ fi
+
+ if ! use bluetooth-sound ; then
+ # Workaround https://gitlab.freedesktop.org/pulseaudio/pulseaudio/merge_requests/10
+ # bug #679526
+ insinto /var/lib/gdm/.config/pulse
+ doins "${FILESDIR}"/default.pa
+ fi
+
+ # install XDG_DATA_DIRS gdm changes
+ echo 'XDG_DATA_DIRS="/usr/share/gdm"' > 99xdg-gdm
+ doenvd 99xdg-gdm
+
+ use branding && newicon "${WORKDIR}/tango-gentoo-v1.1/scalable/gentoo.svg" gentoo-gdm.svg
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ local d ret
+
+ # bug #669146; gdm may crash if /var/lib/gdm subdirs are not owned by gdm:gdm
+ ret=0
+ ebegin "Fixing ${EROOT}/var/lib/gdm ownership"
+ chown --no-dereference gdm:gdm "${EROOT}/var/lib/gdm" || ret=1
+ for d in "${EROOT}/var/lib/gdm/"{.cache,.color,.config,.dbus,.local}; do
+ [[ ! -e "${d}" ]] || chown --no-dereference -R gdm:gdm "${d}" || ret=1
+ done
+ eend ${ret}
+
+ systemd_reenable gdm.service
+ readme.gentoo_print_elog
+
+ udev_reload
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+ udev_reload
+}
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index d01cd64e362c..aaebb6a0364e 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -4,7 +4,9 @@ AUX 46.4-defaults.patch 934 BLAKE2B 597b3e4e844c37e1ea5f2a8c58a702b61b3d9051a261
DIST gnome-shell-45.5.tar.xz 2016720 BLAKE2B a6c28a698a59724ef2381546110caeafd7d9a4541e8046e1d562bc2762660a979fb3b83d0823690fba912ebd2240df746f83e37b2fd722c9a54e038776afbef7 SHA512 4c463635cff3b640ed88f9ada542c98ea6f803c31bce6f67dca2e054ea8cdc1de764d7695bd9365b97d59bd04ad54043b858f26b4553f7a7eff9943d2ffb995b
DIST gnome-shell-45.6.tar.xz 2016488 BLAKE2B 6590c160eabae21e1f5a79787113d02950db52b052330beb9b82d4b837ad7f9038c3c5ae2671c6688710d625a348f9b65b360d53e8d635824ce91be47cc73923 SHA512 7e8ce152cc9fa6374d45cb3163ea8a56db7386c924cfc0799c4d5aec6285e50c7fc8555dd2b8d702fc33f3206027aa2711bbbc1a1e782eaa24e9003e69d7a843
DIST gnome-shell-46.4.tar.xz 2046736 BLAKE2B d511524cf097888df429589ed48973e06395922d3631a2ecc594f90822a8f7c6b53c16c812aece35d7971214603d318a79e6f13a135f7fe43674eebd8376f1f1 SHA512 cf024e90835084d017f5bf866c802ff9b657d5f69af64af5b60b649d591bc8ea74ad48fe625e7691d9132ca288138f1a5a70482a41ca9864cb294c128ecc47b9
+DIST gnome-shell-46.7.tar.xz 2049252 BLAKE2B 5dc0aa3bee1e7a92e0abcff8dd9381c9e94d4fcc0e12116a37481486a1f7535b536138ddd52df18ca5e7a9dbfb65e5534e63d202132dfcbe11b509f9895819c9 SHA512 7d889d72d1d1893727a0e415772d31d414cc4991205a441ecc24863ddc7768b851a83ca3365a6819f4d645ad6057ce6f9a4b810136c5ee461f4b55a5360df740
EBUILD gnome-shell-45.5.ebuild 6622 BLAKE2B 873d703c22fa68390f381c29c86cbc87677b76ef52521e108fb41abf4bd084e19d548734469dcd39f23d6e7a7d3245cd83efa05702ca514994e581bd79a3433e SHA512 e4d05f4d3fdecb80aef9b0de8c080b880ee5bb470681ba52d4400de14dd585ffa5b839b0f585dfe8de452d8801f7b6899e4ee0f155d38913b069c3b235f1a23b
EBUILD gnome-shell-45.6-r1.ebuild 6751 BLAKE2B c7204282b146c14511c90c9b2ff6af1ef9484b6514d1b9b22781d671a45e86e9082e31bdd8662859009863934620b7a2b2a2bc07e6ed100944c8750c16028d50 SHA512 50411bfb7f968ae18ad06e3a4a22d5a6d05ab1670d2660117db873ddf0bc2c2583e14692cba7640386375f590c80ae4d3c583e7ddaca939fb1ae967ce67fc5ab
EBUILD gnome-shell-46.4.ebuild 6619 BLAKE2B 116962b79e3e239d886c5360f1c3dd780971a69a17aab223de62ce6d2ffa5064e4fb79bf4d7eadcf6f314608f837ffc617d20a2c1dc1a5c13afb6162ba256573 SHA512 489c4a1910bb9de34b7fa49c810391d74c14767a7a10ef01e734f561713b0d97894817fbf48bb1764e08ecaedb601b85a4635190965d9ee772aec7ad1d19d1a6
+EBUILD gnome-shell-46.7.ebuild 6576 BLAKE2B 92c360e30187e4b4c9523dd80821171fb356a965d60a665d8475bfb647e16b3037aeb166fb4c536f096b17d40e1c71fec7a6379821191b83708d674ad6e2cb17 SHA512 ecc57f9be104b6242117f9eaddee75f622cf70345c7f0e79ef0610faa17200e3ccdf9e9753367784f7c63bc08a95a65f4f18a267dfefac9ca5b47a3cf768f0a2
MISC metadata.xml 1032 BLAKE2B 2089aace6c8db78bc28c445d9eac949fcea533a9abc26b05430d5e4a11a7bd57ffd00cb8b2edefdd3aa0c0f46e56e573e8f2f544b9e205685877fba957a29de0 SHA512 44e5d05ff803a3fdffe9ad9942da3197150da07e6097f0f92ab9f6b8209b6337149da0a4c535950c879e3184615b2d68a866c1a34d7f2ecdb69810dd5ba0fbd9
diff --git a/gnome-base/gnome-shell/gnome-shell-46.7.ebuild b/gnome-base/gnome-shell/gnome-shell-46.7.ebuild
new file mode 100644
index 000000000000..0bbe4337f05e
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-46.7.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit gnome.org gnome2-utils meson optfeature python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-shell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+IUSE="elogind gtk-doc +ibus +networkmanager pipewire systemd test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.46.0:=
+ >=app-crypt/gcr-3.90.0:4=[introspection]
+ >=dev-libs/glib-2.79.2:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.73.1[cairo]
+ >=gui-libs/gtk-4:4[introspection]
+ >=x11-wm/mutter-46.0:0/14[introspection,test?]
+ >=sys-auth/polkit-0.120_p20220509[introspection]
+ >=gnome-base/gsettings-desktop-schemas-46_beta[introspection]
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-40.0:4=
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ )
+ pipewire? ( >=media-video/pipewire-0.3.49:= )
+ systemd? (
+ >=sys-apps/systemd-246:=
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd]
+ )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-libs/libpulse-2[glib]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/libglvnd[X]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 9. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 10. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue:2.0[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:3.0[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+ gui-libs/libadwaita:1[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data
+ )
+ ibus? ( >=app-i18n/ibus-1.5.26[gtk3,gtk4,introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gnome
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[networkmanager(+)?]
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ >=dev-util/gi-docgen-2021.1
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? (
+ sys-apps/dbus
+ x11-wm/mutter[test]
+ )
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/46.4-defaults.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Hack in correct python shebang
+ sed -e "s:python\.full_path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use pipewire camera_monitor)
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ )
+ meson_src_configure
+}
+
+src_test() {
+ # Reset variables to avoid issues from /etc/profile.d/flatpak.sh file modifying XDG_DATA_DIRS
+ gnome2_environment_reset
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ optfeature "Bluetooth integration" gnome-base/gnome-control-center[bluetooth] net-wireless/gnome-bluetooth:3[introspection]
+ optfeature "Browser extension integration" gnome-extra/gnome-browser-connector
+ optfeature "Screencast/capture support" media-video/pipewire media-libs/gstreamer[introspection] media-libs/gst-plugins-base[introspection] media-libs/gst-plugins-good media-plugins/gst-plugins-vpx
+ optfeature "Weather support" dev-libs/libgweather:4[introspection]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}