summaryrefslogtreecommitdiff
path: root/gnome-base
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/Manifest.gzbin5210 -> 5206 bytes
-rw-r--r--gnome-base/dconf-editor/Manifest2
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild43
-rw-r--r--gnome-base/dconf/Manifest3
-rw-r--r--gnome-base/dconf/dconf-0.40.0.ebuild83
-rw-r--r--gnome-base/dconf/files/0.40.0-bash-completion-dir.patch68
-rw-r--r--gnome-base/gnome-control-center/Manifest2
-rw-r--r--gnome-base/gnome-control-center/gnome-control-center-3.38.4.ebuild176
-rw-r--r--gnome-base/gsettings-desktop-schemas/Manifest2
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild2
-rw-r--r--gnome-base/libgnomecanvas/Manifest2
-rw-r--r--gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild2
-rw-r--r--gnome-base/metadata.xml1
13 files changed, 381 insertions, 5 deletions
diff --git a/gnome-base/Manifest.gz b/gnome-base/Manifest.gz
index f4530b68f8cf..aa73e0e44d79 100644
--- a/gnome-base/Manifest.gz
+++ b/gnome-base/Manifest.gz
Binary files differ
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 1999166c058e..b96dd657a011 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1,3 +1,5 @@
DIST dconf-editor-3.36.4.tar.xz 583084 BLAKE2B 7d7f5164a4917d13372a2bcf7f9fe7b82d630693601bba33da1c4f3afffa58e4589ff90c3e5ca3039351a681eac6584b335171f4dce9d0bfedaed52cc25d505c SHA512 a24fa44830fb0e83834cf912267de6597c1d6bf02e063af4255409d3c9a135fae409116d91751d00ee8d2319e7130606f007af76d3ec9f1380cda98ab2329eff
+DIST dconf-editor-3.38.2.tar.xz 593428 BLAKE2B 6adb53cf2326d25b31d483645df9c2883658d525a32d1eb0ea13d410724911fbeb2ba17a948e4cca5e6a19e187d3cabf0a5722f7aae4dc70bc6699c13be9adc0 SHA512 64bcf7c5cea2c70f2c4ee08832490495c8c2dfee805d6fc27583e1369444f81ef9818f83de7c71228c88322f32c258c4550cc908263f1bb3032ab67e514efb2b
EBUILD dconf-editor-3.36.4.ebuild 813 BLAKE2B e65391c443fecf58357d0a5e4af977e1dc6f62112bb19304613a6c34f41277962c1141053dfbb2fb5f9f0911e119c1238a1a0d8249763164f058e5334de161e9 SHA512 ac96d459b704a45e856a9a1cab563a00996079cf004f197b4b5aad65d3e64f1587918844ea87a8f0642322d8566838b686eab6af309aabf84160ba313be96a22
+EBUILD dconf-editor-3.38.2.ebuild 815 BLAKE2B d1cca311a344ba79f7a4f74a65e01ddc31fb5d6116e2d30459dd42d702b3fc769aa77f94f34fccf06d8fc18c52994b662e6e5d2472066acd9e7308456c00c972 SHA512 828b65a4d05469af3b279638fe0d0b1d48b8d4eecb45e311a69cb5fd5f795255a432349d7f0e8d009087888cf44ad30224f1215b7356f316ea19a4cb39226ee7
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
new file mode 100644
index 000000000000..21fa99568f71
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.38.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-base/dconf/Manifest b/gnome-base/dconf/Manifest
index 266cc4f7e090..e1b3bd03da75 100644
--- a/gnome-base/dconf/Manifest
+++ b/gnome-base/dconf/Manifest
@@ -1,8 +1,11 @@
AUX 0.30.1-bash-completion-dir.patch 3222 BLAKE2B 977be3dd9cbee50bc976fbae125b058579587dcf55918b07b4bc9708dc9cc19192acddfb225c540806b4866a2e431acc42d461f91fdd935626af366341617595 SHA512 aeaba2126d4e87caf7c467118f2e2d42330fbf5c1d0786c52a2782550c64f41e482034c08e4624cc231e49ec9f39e824d29796b4078090613cfe54adbd420eaa
AUX 0.32.0-drop-vapigen-dep.patch 1123 BLAKE2B 921e0bfebf9dfa67e55cda7c410c790e07d5d55d9c24d897fd43bacf524bde2de4fce07905a8c2298130af5c94a309a8bd82d0d549f2e344d653f9c9e1335965 SHA512 c26e44fd38e46f1df60d2a13cc40415af9298629ad3c0d12a203bf483a0577c24af2bedfb8c1e8e35855eefa317a0afced78b74f217a13a2429bb8ae73d8413f
AUX 0.32.0-meson-0.52-compat.patch 1148 BLAKE2B d33127e2e765f3f19282b33852b00b8a08f4977c856a94321b616e5135b3618477a44812a7429148018c915d716f35c6296e3c72c247970adedc9331af7bfdc6 SHA512 a4b9a1c6b6f16a4f5ea7a250d0a2949c1906813cefc985706575865abc03dc715f6d283887b081bc906a7a439fff0ef4fac57b3de3a4ea40ba2dc19e51db4664
+AUX 0.40.0-bash-completion-dir.patch 3029 BLAKE2B 6695d75088c96060b0b0a34f928d8db9b06528d97ff3fe44b5911ef1c04b1a68aa807eea507213e316283db8b1d73218255e12c378aafb3fc920ab39d3f092b4 SHA512 4fead302c92327787f26b0001ced07dcd176abbc5142119a19be0b48893d777f1cfc4559f37a37a5c589221cb2c81f1627626371d8a3ad58bb8c542806ac7b87
DIST dconf-0.34.0.tar.xz 112876 BLAKE2B 6890cd82a3ba81eac8c72dda93ebf1b82f3002b735bf2e059ba07a2f0f3817978a9e4f5dd37a9efab728fc2a4e20c34c519f9eeb3915d705ff8a3c4a65f9ab41 SHA512 8b28373f31fe36ba3f21f56fca84563681c3648ff595709880cd9ac49fc6b130ac375fb89fd585f1dd62b5a2f728127292ea57d18feca1147b709a93e8c4c743
DIST dconf-0.36.0.tar.xz 114828 BLAKE2B 033cb2e095d9dac72bd07c5fa8280a3e1012aac6c1b0657d5455c2a519617be9112acca702ec4078554a814f36d12ee8e25201cc5b8aed2d33a32ef14e2f6fa5 SHA512 fed0b4ac13dfeff3bbe428a5c25408a0f13610219e561841a3af75cf18f9c630c385989b700c081b79ab53c00bdecf43c7c94979312c047faefbda4b2653d40d
+DIST dconf-0.40.0.tar.xz 117764 BLAKE2B bdbc48b71e46fdc4353358cd08fb96933d07af587300a6f91bc45826aeafb3f34f482fe6e09041dd839e507b863a8e33d09bad88a91c1c868983f8afb52c5c85 SHA512 71396d71f24f47653181482b052fdfc63795c50c373de34e2fb93e16101745daa7e81192b79a102d5389911cea34138eedf3ac32bc80562018e8a7f31963559a
EBUILD dconf-0.34.0.ebuild 2192 BLAKE2B 74e61c5af928ef2effa2d23593105fa50e0487b3d842b39a66c210a1b06b194d34b95d03cfa536764971b29e5cc139776641f77accb85f8f3be5ccad478c59a1 SHA512 d474a1b2ec9f6d30579c853bdf9a7e53ee19913553a4c0d62adf586de5633552966e9567439f2769f7c671b87286c5eef613241d64d0d4caff624344b19d9902
EBUILD dconf-0.36.0.ebuild 2104 BLAKE2B 6989287b32971b02a72e5c14da091555707dc3b3e35d87eef39a7be6981e4d90b221b8f73d029f4624815a40532a12c11ea381d69ca4f79c56303e05d2c02f2d SHA512 3d192e4cbf500f42e51d0c938581a3cded0aa883eac39b98c058c6573552a1aac0e8b0c4b7a1f92842b69e77407447352c8a204168e7b7d2bbc8765a3c7d006f
+EBUILD dconf-0.40.0.ebuild 2170 BLAKE2B 268f0db3b8cb8124bb2b5c9e9d66a5bf26807b3dd9dcd0221d1a4196049a514b9d53f10af1608bb5628a9ff99bb23a4fb8f009d8ff1393e8104c8acd436b879d SHA512 6798b88f00a2cfcc1b098d1f401a579a32131224663e6f235677a81810750914ec1b1695ee72f5d248681064999b888e1e75590a54bdff6b753145708cbaae84
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/dconf/dconf-0.40.0.ebuild b/gnome-base/dconf/dconf-0.40.0.ebuild
new file mode 100644
index 000000000000..d0515385aa74
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.40.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 gnome.org gnome2-utils meson systemd virtualx xdg
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/Projects/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="gtk-doc"
+RESTRICT="!test? ( test )" # IUSE=test comes from virtualx.eclass
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ sys-apps/dbus
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.2
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ gtk-doc? ( >=dev-util/gtk-doc-1.15 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.40.0-bash-completion-dir.patch
+ "${FILESDIR}"/0.32.0-drop-vapigen-dep.patch # .vapi/.deps are pregenerated, just install them without a vala dep
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dbash_completion_dir="$(get_bashcompdir)"
+ -Dman=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dvapi=true
+ -Dsystemduserunitdir=$(systemd_get_userunitdir)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ # This snippet can't be removed until gconf package is
+ # ensured to not install a /etc/env.d/50gconf and then
+ # still consider the CONFIG_PROTECT_MASK bit.
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_giomodule_cache_update
+
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_giomodule_cache_update
+}
diff --git a/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch b/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch
new file mode 100644
index 000000000000..43bbe57294d9
--- /dev/null
+++ b/gnome-base/dconf/files/0.40.0-bash-completion-dir.patch
@@ -0,0 +1,68 @@
+From 43393af96308d001c30ac14c32000519253fe910 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 22 Feb 2019 22:06:18 +0200
+Subject: [PATCH] build: Allow passing bash-completion dir and have a generic
+ fallback
+
+With autotools the installation path was just hardcoded to the usual
+location. In meson it was made to always check the path from
+bash-completion.pc, but some downstream might want to install the
+file without a bash-completion build-dep. Allow installing the
+completion file to a passed directory, and add back the fallback
+path if an explicit directory isn't passed and bash-completion
+package isn't found. This is also what the tracker project does.
+---
+ meson.build | 26 ++++++++++++++++++--------
+ meson_options.txt | 2 +-
+ 2 files changed, 19 insertions(+), 9 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index b81a81a..7c790c1 100644
+--- a/meson.build
++++ b/meson.build
+@@ -62,14 +62,24 @@ if systemd_userunitdir == ''
+ endif
+ endif
+
+-enable_bash_completion = get_option('bash_completion')
+-if enable_bash_completion
+- bash_completion_dep = dependency('bash-completion')
+- completions_dir = bash_completion_dep.get_pkgconfig_variable(
+- 'completionsdir',
+- # bash-completion 2.10 changed the substitutions
+- define_variable: bash_completion_dep.version().version_compare('>= 2.10') ? ['datadir', dconf_datadir] : ['prefix', dconf_prefix],
+- )
++enable_bash_completion = false
++if get_option('bash_completion_dir') == 'yes' or get_option('bash_completion_dir') == 'auto'
++ bash_completion_dep = dependency('bash-completion', required: false)
++ if bash_completion_dep.found()
++ completions_dir = bash_completion_dep.get_pkgconfig_variable(
++ 'completionsdir',
++ # bash-completion 2.10 changed the substitutions
++ define_variable: bash_completion_dep.version().version_compare('>= 2.10') ? ['datadir', dconf_datadir] : ['prefix', dconf_prefix],
++ )
++ else
++ completions_dir = join_paths(dconf_datadir, 'bash-completion', 'completions')
++ endif
++ enable_bash_completion = true
++elif get_option('bash_completion_dir') == 'no' or get_option('bash_completion_dir') == ''
++ enable_bash_completion = false
++else
++ enable_bash_completion = true
++ completions_dir = get_option('bash_completion_dir')
+ endif
+
+ configure_file(
+diff --git a/meson_options.txt b/meson_options.txt
+index 1b85d5d..7f5afcc 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,4 @@
+-option('bash_completion', type: 'boolean', value: true, description: 'install bash completion files')
++option('bash_completion_dir', type: 'string', value: 'yes', description: 'directory to install Bash completion files (or "yes" for default directory, "no" to disable installation)')
+ option('man', type: 'boolean', value: true, description: 'generate man pages')
+ option('gtk_doc', type: 'boolean', value: false, description: 'use gtk-doc to build documentation')
+ option('vapi', type: 'boolean', value: true, description: 'install dconf client vapi')
+--
+2.26.2
+
diff --git a/gnome-base/gnome-control-center/Manifest b/gnome-base/gnome-control-center/Manifest
index 3b201217bef7..d87b453a1f25 100644
--- a/gnome-base/gnome-control-center/Manifest
+++ b/gnome-base/gnome-control-center/Manifest
@@ -4,7 +4,9 @@ DIST gnome-control-center-3.36.5-patchset.tar.xz 7288 BLAKE2B 56f71bc1a8c9f5a62e
DIST gnome-control-center-3.36.5.tar.xz 6304804 BLAKE2B c4e95784ff1877e716f23ea421d0d4997691e2aa15ce24eae35d9ecac167c48443e8f5180ff3359be75914512c240e4ef2ef8a2fdc51f1c6b15275eadef2c3bb SHA512 4a5470dc18366172198a68f8e0598647c0cae1fbcc00eec26dccf7320f0e3aca4a7326fbf0e616fd7e44ab1faacefaa9342322efcf79039122216c644c490b52
DIST gnome-control-center-3.38.3-patchset.tar.xz 7308 BLAKE2B 72acdb825d48c7077d15f7273765db2ccbef89a839466a4482d9f6ae9eae3a2144556a048f2a6e146ea4e3435c13f0a72bf499c44d34bcbed505d6186d8bf008 SHA512 2498abd83e0100efa4c83886ce3e7f7d4468e41aab12c5338987832cb305c215abe75b4fff65217511bbe174b6b1b601af988c5588523e0346855aba7842092b
DIST gnome-control-center-3.38.3.tar.xz 6434672 BLAKE2B e95a9a1c487e1a3d6a0e64c61fd9502d1983827ff0a26ed03a0e48339917ae49855016ac3699c3940764185041659d865db51fd95e19bbb588c62277218c609d SHA512 25b8ff6e44be5e679666ae44e12deedf5dbef9317089381cd2075efc2321abca91ac1ad268242fb16a0b7f411ad98d9ab50073f745060d6525e0648585333e3e
+DIST gnome-control-center-3.38.4.tar.xz 6434656 BLAKE2B 6201344c3ce4a1e85c8becde5df24d0aaa294ba0f135220fa1bd1ca079fb99ea30a4bb9f6403f17584bb1299b7d3edf1300fa94fca44a75bd947c84cc257be35 SHA512 9fa90b33af09fe5458c2db8782079d992f18bc36cdd6623239b48d6c8f242fa9b56275ee7c6920f313efcd2f8f1c65a43a8f3f1c100489a0bcade26d045eb3c7
EBUILD gnome-control-center-3.36.4.ebuild 6333 BLAKE2B e2710b49f78faedc5066a8c0c62d3a712c1eaae8118673d132f418ecdf0083d3051d1150cec64101da212e6f7b02f9119c9e62d491b70169d1fb3c27e482d3e2 SHA512 1c27bd276acf3f80caea1a67487eb885752726850127bc39ee4edb4b74f7f4e0b69034f2954b29d71a4f0efa097b7d09cc983263d3269465d92ec9b61b8a6316
EBUILD gnome-control-center-3.36.5.ebuild 6341 BLAKE2B 6e8255b594daef3763ec65ef68ec32b6e09c8087abb0c6e42003737000ea5687b40b4d52a3a066d4c3590a3a211c03fc9e60d3fea107c9ccdf5831dd9d0af911 SHA512 306f9e56bff6c11b0e2b364391894633aa18614d7a632100e333fcab7e00a64806da39f7005191403c08241d90cac28bbaba524778a2b7babc3818894858dcac
EBUILD gnome-control-center-3.38.3.ebuild 6226 BLAKE2B d3f722ecacaa770962b4f859bafe4e9427934c04205d421b9824c1a5381314631f9065bbb5207912a7887d8bcfbc7613d572cb27bda1ccaac06d1e282f94d634 SHA512 b142a2399ac3c5d5b5316a87b10722b2af9ca40d1e88c706e6b4fd34e2c5310f3393ef3fc56575357c4f720976288c3a34efa812833af5309c8b1158b741d5be
+EBUILD gnome-control-center-3.38.4.ebuild 6235 BLAKE2B 1691b82677c5ab8ee1afd37a121fd20383be5e69c347ca870aa0a58362c2865ac04c6d247a328a4b753249947de2fe55e42c3d6bff8592b85dee98e66eafc990 SHA512 46b694410f5755a5c360e027668d6b5ed4130cb650259ef3497d8191e6b2976b61f8c7b0490b4c29517bce4472b7e6c6191b6fa06d74096d3edaedf3fc09271e
MISC metadata.xml 588 BLAKE2B 6fb4fefc43b162c8ac2a671ed7a6878ebe19edeaf018bb37f32a0c0aa6208b8cb68392b24fde56e1aaf5227756b157fbfa10470c350bb472c270ac7436827ff3 SHA512 d2891d89abf4a64e97ab84ed45e45b4115ebb1990b2ef8a91f069433a61aea4d97d060376e088aec5e9aec7475c0263ac072f081cb5f0c3d67206ed077051e1d
diff --git a/gnome-base/gnome-control-center/gnome-control-center-3.38.4.ebuild b/gnome-base/gnome-control-center/gnome-control-center-3.38.4.ebuild
new file mode 100644
index 000000000000..ac894c3d8ce2
--- /dev/null
+++ b/gnome-base/gnome-control-center/gnome-control-center-3.38.4.ebuild
@@ -0,0 +1,176 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="GNOME's main interface to configure various aspects of the desktop"
+HOMEPAGE="https://git.gnome.org/browse/gnome-control-center/"
+SRC_URI+=" https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.38.3-patchset.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="2"
+IUSE="+bluetooth +cups debug elogind flickr +gnome-online-accounts +ibus input_devices_wacom kerberos networkmanager systemd test v4l wayland"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ flickr? ( gnome-online-accounts )
+ ^^ ( elogind systemd )
+" # Theoretically "?? ( elogind systemd )" is fine too, lacking some functionality at runtime, but needs testing if handled gracefully enough
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+
+# kerberos unfortunately means mit-krb5; build fails with heimdal
+# display panel requires colord and gnome-settings-daemon[colord]
+# wacom panel requires gsd-enums.h from gsd at build time, probably also runtime support
+# printer panel requires cups and smbclient (the latter is not patched yet to be separately optional)
+# First block is toplevel meson.build deps in order of occurrence (plus deeper deps if in same conditional). Second block is dependency() from subdir meson.builds, sorted by directory name occurrence order
+DEPEND="
+ >=gui-libs/libhandy-1:1=
+ gnome-online-accounts? ( >=net-libs/gnome-online-accounts-3.25.3:= )
+ >=media-sound/pulseaudio-2.0[glib]
+ >=sys-apps/accountsservice-0.6.39
+ >=x11-misc/colord-0.1.34:0=
+ >=x11-libs/gdk-pixbuf-2.23.0:2
+ >=dev-libs/glib-2.56.0:2
+ >=gnome-base/gnome-desktop-3.27.90:3=
+ >=gnome-base/gnome-settings-daemon-3.27.90[colord,input_devices_wacom?]
+ >=gnome-base/gsettings-desktop-schemas-3.37.0
+ dev-libs/libxml2:2
+ >=sys-auth/polkit-0.114
+ >=sys-power/upower-0.99.8:=
+ >=dev-libs/libgudev-232
+ x11-libs/libX11
+ >=x11-libs/libXi-1.2
+ media-libs/libepoxy
+ flickr? ( >=media-libs/grilo-0.3.0:0.3= )
+ >=x11-libs/gtk+-3.22.0:3[X,wayland=]
+ cups? (
+ >=net-print/cups-1.7[dbus]
+ >=net-fs/samba-4.0.0[client]
+ )
+ v4l? (
+ >=media-video/cheese-3.28.0 )
+ ibus? ( >=app-i18n/ibus-1.5.2 )
+ networkmanager? (
+ >=net-libs/libnma-1.8.0
+ >=net-misc/networkmanager-1.20.0:=[modemmanager]
+ >=net-misc/modemmanager-0.7.990 )
+ bluetooth? ( >=net-wireless/gnome-bluetooth-3.18.2:= )
+ input_devices_wacom? ( >=dev-libs/libwacom-0.27 )
+ kerberos? ( app-crypt/mit-krb5 )
+
+ x11-libs/cairo[glib]
+ >=x11-libs/colord-gtk-0.1.24
+ net-libs/libsoup:2.4
+ media-libs/fontconfig
+ gnome-base/libgtop:2=
+ >=sys-fs/udisks-2.1.8:2
+ app-crypt/libsecret
+ media-libs/gsound
+ >=dev-libs/libpwquality-1.2.2
+"
+# systemd/elogind USE flagged because package manager will potentially try to satisfy a
+# "|| ( systemd ( elogind openrc-settingsd)" via systemd if openrc-settingsd isn't already installed.
+# libgnomekbd needed only for gkbd-keyboard-display tool
+# gnome-color-manager needed for gcm-calibrate and gcm-viewer calls from color panel
+# <gnome-color-manager-3.1.2 has file collisions with g-c-c-3.1.x
+#
+# mouse panel needs a concrete set of X11 drivers at runtime, bug #580474
+# Also we need newer driver versions to allow wacom and libinput drivers to
+# not collide
+#
+# system-config-printer provides org.fedoraproject.Config.Printing service and interface
+# cups-pk-helper provides org.opensuse.cupspkhelper.mechanism.all-edit policykit helper policy
+RDEPEND="${DEPEND}
+ systemd? ( >=sys-apps/systemd-31 )
+ elogind? ( app-admin/openrc-settingsd
+ sys-auth/elogind )
+ x11-themes/adwaita-icon-theme
+ >=gnome-extra/gnome-color-manager-3.1.2
+ cups? (
+ app-admin/system-config-printer
+ net-print/cups-pk-helper )
+ >=gnome-base/libgnomekbd-3
+ wayland? ( dev-libs/libinput )
+ !wayland? (
+ >=x11-drivers/xf86-input-libinput-0.19.0
+ input_devices_wacom? ( >=x11-drivers/xf86-input-wacom-0.33.0 ) )
+ flickr? ( media-plugins/grilo-plugins:0.3[flickr,gnome-online-accounts] )
+"
+# PDEPEND to avoid circular dependency; gnome-session-check-accelerated called by info panel
+# gnome-session-2.91.6-r1 also needed so that 10-user-dirs-update is run at login
+PDEPEND=">=gnome-base/gnome-session-2.91.6-r1
+ networkmanager? ( gnome-extra/nm-applet )" # networking panel can call into nm-connection-editor
+
+BDEPEND="
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ x11-base/xorg-proto
+ dev-libs/libxml2:2
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( $(python_gen_any_dep '
+ dev-python/dbusmock[${PYTHON_USEDEP}]
+ ') )
+"
+
+PATCHES=(
+ # Patches from gnome-3-38 branch on top of 3.38.3
+ # Makes some panels and dependencies optional
+ # https://bugzilla.gnome.org/686840, 697478, 700145
+ # Fix some absolute paths to be appropriate for Gentoo
+ "${WORKDIR}"/patches/
+)
+
+python_check_deps() {
+ use test && \
+ has_version "dev-python/dbusmock[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ xdg_src_prepare
+ # Mark python tests with shebang executable, so that meson will launch them directly, instead
+ # of via its own python-single-r1 version, which might not match what we get from python_check_deps
+ chmod a+x tests/network/test-network-panel.py tests/datetime/test-datetime.py || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth)
+ $(meson_use v4l cheese)
+ -Dcups=$(usex cups enabled disabled)
+ -Ddocumentation=true # manpage
+ -Dgoa=$(usex gnome-online-accounts enabled disabled)
+ -Dgrilo=$(usex flickr enabled disabled)
+ $(meson_use ibus)
+ -Dkerberos=$(usex kerberos enabled disabled)
+ -Dmalcontent=false # unpackaged
+ $(meson_use networkmanager network_manager)
+ -Dprivileged_group=wheel
+ -Dsnap=false
+ $(meson_use test tests)
+ $(meson_use debug tracing)
+ $(meson_use input_devices_wacom wacom)
+ #$(meson_use wayland) # doesn't do anything in 3.34 and 3.36 due to unified gudev handling code
+ # bashcompletions installed to $datadir/bash-completion/completions by v3.28.2, which is the same as $(get_bashcompdir)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
diff --git a/gnome-base/gsettings-desktop-schemas/Manifest b/gnome-base/gsettings-desktop-schemas/Manifest
index 902a503dac64..2fc4cf6d7694 100644
--- a/gnome-base/gsettings-desktop-schemas/Manifest
+++ b/gnome-base/gsettings-desktop-schemas/Manifest
@@ -4,5 +4,5 @@ DIST gsettings-desktop-schemas-3.36.1.tar.xz 679788 BLAKE2B f49f98274f48cdb2eab0
DIST gsettings-desktop-schemas-3.38.0.tar.xz 685868 BLAKE2B a5fe8baf6d7178cfba74c82974dfb854fbc2accfb9c98db2edbf46271b54626150a570fb3b578cdd86acfd1b21b432da0947e273c3ab94ec3f416c4a51b44e4a SHA512 5af7da90b8e7eec1c98e9e44653955f2882961dd9b5e2bf00e4eeb9f4f1149ae5171c600d457c6ab9c7482471c1a0e98f92f645a7ee7298e1b843c608f660756
EBUILD gsettings-desktop-schemas-3.34.0.ebuild 1018 BLAKE2B 4a4cf4ac885691a18cd84cd6eb1914bee7c298559b8159256b6de4cc9ba89a6fbdaa9441724284c59eb07d63fc75a18db328c748b7df90aca75d4ab53d966f8a SHA512 ba32747ee607c3ee8cfb4ba431fd3f9e2ed16c591ce8e48304a55a79b0c6689ded833af4fd6b2851271c2f71cb0c0bb3c9d66d4b3aeed904fac9068c77af4332
EBUILD gsettings-desktop-schemas-3.36.1.ebuild 968 BLAKE2B d539da134dd9ff1d8bd9ba4b014da693e481f1dfbce6ed4ce7e2ceb07d43b1370fc5866dc568b6d9485e419c65e12b41a0152286630f9e4a976a006fb33f3d5d SHA512 fb8c518b6c021ee7a56201f2d56119cde972fed10ef70ac1646fe021057c9e1ab795d33b1e8a0b0efc19b8fd3a6483c47101184b33a284131fd249dfc50f0a07
-EBUILD gsettings-desktop-schemas-3.38.0.ebuild 975 BLAKE2B 8d6f6901c3eb935e6173c02b095bf2bea9db2872a32a60cf3c6460ddd9aea239591018145173e714715dbbe33b3b169181be3259c51720a1cb8c7a53a521189c SHA512 f9235d131be2b3b3821c6f95ade04f215ba4ff20e0b2fbac5ccb27416085d26aa356549df00fa03a5c7c42f545fbbfb94162a32232c7c13dfb6b03d453e45082
+EBUILD gsettings-desktop-schemas-3.38.0.ebuild 974 BLAKE2B 050adacd85722f42ce0a99efa3b85056f2073d8e2057ddf328878e685d55de45cac8f274aadb13f3be74eda179c09901d86de54210c87571a5a121447b44e8d3 SHA512 58e524868a4d936b965f54702c2d91f62197dcd2c0fd17b2f44e5d10145c9ce9087068fb6fdd7abc1a02d66501c62f4eb12bc224ef9dbfa6e5bd1b71f86574ee
MISC metadata.xml 249 BLAKE2B e71e1b95fee768c696704acbf7e3cf0e599ed2bc8de92bae0141d1194ef9e842bdc292798904487a9b90ddfda9b0e84abd3b76b1518576c1d288240e4e46f110 SHA512 c40662134899a5c9f0369a1017806f35adf3280a0b3c91726f7a8ca6012a073a8b471583f5bfb6fe95faac1dcf607e8e2e43f8c91d48ec46f4a8824e2f551506
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild
index 5af733e566ef..2e820a1526ca 100644
--- a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-3.38.0.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://git.gnome.org/browse/gsettings-desktop-schemas"
LICENSE="LGPL-2.1+"
SLOT="0"
IUSE="+introspection"
-KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
BDEPEND="
introspection? ( >=dev-libs/gobject-introspection-1.54:= )
diff --git a/gnome-base/libgnomecanvas/Manifest b/gnome-base/libgnomecanvas/Manifest
index ca5b60717c11..8b60bae3047b 100644
--- a/gnome-base/libgnomecanvas/Manifest
+++ b/gnome-base/libgnomecanvas/Manifest
@@ -1,3 +1,3 @@
DIST libgnomecanvas-2.30.3.tar.bz2 574139 BLAKE2B 25f42bdb24899aaf6b2daf19242ba67a4bdae9a51bffaddc413b65a48843ccea1de11e18a82cc40ddec566ab25bf133811f00a8e7667a66b228ad8c855a8773d SHA512 b5bfa2133f5172abd5228d467db4d980dd4ac125cdbf55dcc1d5055dc3330861320c12cccb52ea63ba7f69824504c9d25781cd78001dc7a92b11c6f7e0c550de
-EBUILD libgnomecanvas-2.30.3-r1.ebuild 1643 BLAKE2B bb935777d998d3efc6c8c0a2d5261e70480333d029c691328c384e3dc0c43e06f6d7c33651f6caa2f74a57caedddf6afd67b32bf385152d8c35a447f4330bb0f SHA512 800a16b7257a787c1af9e91710174ed758c5c48b08dff158ff2a6f0606a91e1acb36e685da07d1cd9f72267e99081bbdf6e2e5a7984ebf92ce95947550f13b31
+EBUILD libgnomecanvas-2.30.3-r1.ebuild 1642 BLAKE2B e9d1e2e8cd9feabf9201430d3da48b016cd10f9349f7e9d0daae9ebcd45fdf1a9796bef5eb6d12d80bc8ebbd470fa023995f09085f93b3ec6f525eaaccb024ab SHA512 9e5f8b29ef99cbb8393592326a2e50238a762ef508f9b5a0b043f7dca09241ef418556389c1a904bc808c7dab06837582254c84439c13d024305905ee30aabae
MISC metadata.xml 310 BLAKE2B bd322cd2300711715469acaec5e2930542ea48dde8e3444d465c9dfc13dbaddbd49885ddf04a643c07d67d75316f080ca587083001a0dc33cfb15b38b9bf7c19 SHA512 15504f6f0f8ba8e905677b293df85f64ec929c96b22a81a57803c47657a0f054039a1257086c02af49ab89a57b16d31d32619ccdf1f53ac2de93ce8fc2f99c12
diff --git a/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild b/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild
index 1e832af54bea..0d55b4313bcf 100644
--- a/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild
+++ b/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://library.gnome.org/devel/libgnomecanvas/stable/"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="glade"
RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
diff --git a/gnome-base/metadata.xml b/gnome-base/metadata.xml
index 0fe9232faaf5..53d401cec996 100644
--- a/gnome-base/metadata.xml
+++ b/gnome-base/metadata.xml
@@ -29,4 +29,3 @@
Kategoria gnome-base zawiera podstawowe pakiety środowiska GNOME.
</longdescription>
</catmetadata>
-