summaryrefslogtreecommitdiff
path: root/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild')
-rw-r--r--gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild
new file mode 100644
index 000000000000..42509dcaeef9
--- /dev/null
+++ b/gnome-base/gsettings-desktop-schemas/gsettings-desktop-schemas-43.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit gnome.org gnome2-utils meson python-any-r1 xdg
+
+DESCRIPTION="Collection of GSettings schemas for GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gsettings-desktop-schemas"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~x86-solaris"
+
+BDEPEND="
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+"
+
+PATCHES=(
+ # Revert change to 'Source Code Pro 10' and 'Cantarell 11' fonts back to generic sans and monospace aliases
+ "${FILESDIR}"/3.32.0-default-fonts.patch
+)
+
+src_prepare() {
+ default
+
+ python_fix_shebang build-aux/meson/post-install.py
+}
+
+src_configure() {
+ meson_src_configure $(meson_use introspection)
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}