summaryrefslogtreecommitdiff
path: root/gnome-base/gnome-shell
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/gnome-shell')
-rw-r--r--gnome-base/gnome-shell/Manifest2
-rw-r--r--gnome-base/gnome-shell/gnome-shell-43.2.ebuild182
2 files changed, 184 insertions, 0 deletions
diff --git a/gnome-base/gnome-shell/Manifest b/gnome-base/gnome-shell/Manifest
index b6f503237f27..25f9e359223e 100644
--- a/gnome-base/gnome-shell/Manifest
+++ b/gnome-base/gnome-shell/Manifest
@@ -2,6 +2,8 @@ AUX 40.0-defaults.patch 1412 BLAKE2B e36f7215cf756586479b8bdc71339beb3bbde53ca97
AUX 42.0-optional-bluetooth.patch 2032 BLAKE2B 635ba18f5bb5ca0c9f44fe11c2b52652355e1de4647c277524e3f19ef6d57870e75f32b8a2be10eb4e3be4ecf885765b8f0899ab71906f71324795763effa23a SHA512 5fb17c6ffd0486e43b5451747b346e5e9feb3f918f4ef23adc517c43bf61eb5b8850b03022e84848e446de1f0b2145a9dd2b954dde9994e9da176559cd6e48a8
DIST gnome-shell-42.5.tar.xz 1930668 BLAKE2B 0442ef92588e9891082c024d1e3b4ddb105a01ef5b7913ac8f1d2cac1af1c2ae8efd18184c511c554e41d8c0540c8712b7ef39ba1a9cac8c6c9336bb7b4cb320 SHA512 575559b99161b7045b04fc100cde719bbca83d90f78b673acc2189f3bb5104fd14f40da7d19611b154976f1c006e0dc2ff8cc124dc816da765c933fdda0624d9
DIST gnome-shell-43.1.tar.xz 1947824 BLAKE2B d03bf5e970a92762724e5e1ab534e610f73b1c4af48b42fd676304f0d75808fcf5ba21ab9b9a0503cc2a806b826340d7d441da4b3ce51b881ffd4cb08132ae86 SHA512 1e41f0ce38b285aca1f9189fdb50e4d409232554da73e9c08e21b5888d35bad3e2bf4a47e93fdf20798ea6f63864223088b78cab7c63fc1105cd955701ea2e81
+DIST gnome-shell-43.2.tar.xz 1946776 BLAKE2B 0b581ed84bb3b8804cb4b5be07ae6be479f1092abf4c018d140edc81dcf0f88dc6c3321f591bc55c16e2141b4dd59e353c1f244749de13e4571a5b5aba6ad57d SHA512 f25754b60696723db3db4141eb14fda88f5d913cc8a9d7270a34b9a1493f9bd4caadf45b142fd0bd82f594d9fb47980c3b0242bb58ee184a61968f0d1f09bfc4
EBUILD gnome-shell-42.5-r2.ebuild 7512 BLAKE2B 38c7c58e13fb94ed45205192c6da4b6f98c0bd9bd7f0b3e05cf873904e3560b5018885fdfc84f0c799a92fcc5d2314c07f1797a4dce02b29e72883eee5ac40ef SHA512 a27b74b05f7a9540eecf73fce261fd0434c8d86a321a7d53db7b11c496892b7be55f671e2d2edfacec25c8638308bc74f264e45b589f6d52e04328560941704a
EBUILD gnome-shell-43.1.ebuild 6433 BLAKE2B 621e39f822dfa659dbedaebcdf8eb3985565b3648646522458227f7ad455068bae108c016133236f04ce4c496c4cf725009a893e9b5f6e6aaafdf95fdbd92b27 SHA512 41ffd85589ecbb2e59a7364631eabfc51c435004916db3418c218371a974790b68aa6d679866b5ae63130d7336a6b2b13e4582ef1216b6291ea7a4d16c7e6194
+EBUILD gnome-shell-43.2.ebuild 6434 BLAKE2B 6410bd66ebf82f075fab9833f3b1153d0f9907521b6158453b11fabd346b001d528c7455e061e3b72e91b40b49f0e0b87f175e3b0dca5610fe8750d31a876723 SHA512 b7b6b20ce574fe5e269fc9e1b56e7c9bbf07ec31d51b947c4c6c7c36982fbd3da66a2c0dee72d080768a0f98a2fa65eaa94ee5bed90757ce8cc4e4fbe7bba5f5
MISC metadata.xml 1187 BLAKE2B 112179de090fbd712f5af966853e0837f7b0cdd78e377fce9c8d3c6078e17ac98acfaabf93dfc738a45fb78a94f82903f5d8609bdd7f3769877e6ac24a5424a1 SHA512 f679fd454c50795c347235ebab1ce8b2e070c4afd797ce574226dee7aae25991a00e2c98000b11178f8aa943af1be8652b585937f8cab41ef349b6ee7b897d05
diff --git a/gnome-base/gnome-shell/gnome-shell-43.2.ebuild b/gnome-base/gnome-shell/gnome-shell-43.2.ebuild
new file mode 100644
index 000000000000..544a7e2eb14a
--- /dev/null
+++ b/gnome-base/gnome-shell/gnome-shell-43.2.ebuild
@@ -0,0 +1,182 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson optfeature python-single-r1 virtualx xdg
+
+DESCRIPTION="Provides core UI functions for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell https://gitlab.gnome.org/GNOME/gnome-shell"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+IUSE="elogind gtk-doc +ibus +networkmanager systemd test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( elogind systemd )"
+RESTRICT="!test? ( test )"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+# libXfixes-5.0 needed for pointer barriers and #include <X11/extensions/Xfixes.h>
+DEPEND="
+ >=gnome-extra/evolution-data-server-3.33.1:=
+ >=app-crypt/gcr-3.90.0:4=[introspection]
+ >=dev-libs/glib-2.68:2
+ >=dev-libs/gobject-introspection-1.49.1:=
+ >=dev-libs/gjs-1.73.1[cairo]
+ >=x11-libs/gtk+-3.15.0:3[introspection]
+ >=x11-wm/mutter-43.0:0/11[introspection,test?]
+ >=sys-auth/polkit-0.120_p20220509[introspection]
+ >=gnome-base/gsettings-desktop-schemas-42_beta[introspection]
+ >=x11-libs/startup-notification-0.11
+ >=app-i18n/ibus-1.5.19
+ >=gnome-base/gnome-desktop-3.35.90:3=[introspection]
+ networkmanager? (
+ >=net-misc/networkmanager-1.10.4[introspection]
+ net-libs/libnma[introspection]
+ >=app-crypt/libsecret-0.18
+ dev-libs/dbus-glib
+ )
+ systemd? (
+ >=sys-apps/systemd-242:=
+ >=gnome-base/gnome-desktop-3.34.2:3=[systemd]
+ )
+ elogind? ( >=sys-auth/elogind-237 )
+
+ app-arch/gnome-autoar
+ dev-libs/json-glib
+
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ dev-libs/libxml2:2
+ x11-libs/libX11
+
+ >=media-libs/libpulse-2[glib]
+ dev-libs/libical:=
+ >=x11-libs/libXfixes-5.0
+
+ gui-libs/gtk:4[introspection]
+
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ media-libs/libglvnd[X]
+"
+# Runtime-only deps are probably incomplete and approximate.
+# Introspection deps generated from inspection of the output of:
+# for i in `rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- |sort -u`; do echo $i ;done |cut -d, -f1 |sort -u
+# or
+# rg -INUo 'const(?s).*imports.gi' |cut -d= -f1 |cut -c7- | sed -e 's:[{}]::g' | awk '{$1=$1; print}' | awk -F',' '{$1=$1;print}' | tr ' ' '\n' | sort -u | sed -e 's/://g'
+# These will give a lot of unnecessary things due to greedy matching (TODO), and `(?s).*?` doesn't seem to work as desired.
+# Compare with `grep -rhI 'imports.gi.versions' |sort -u` for any SLOT requirements
+# Each block:
+# 1. Introspection stuff needed via imports.gi (those that build time check may be listed above already)
+# 2. gnome-session needed for shutdown/reboot/inhibitors/etc
+# 3. Control shell settings
+# 4. xdg-utils needed for xdg-open, used by extension tool
+# 5. adwaita-icon-theme needed for various icons & arrows (3.26 for new video-joined-displays-symbolic and co icons; review for 3.28+)
+# 6. mobile-broadband-provider-info, timezone-data for shell-mobile-providers.c # TODO: Review
+# 7. IBus is needed for nls integration
+# 8. Cantarell font used in gnome-shell global CSS (if removing this for some reason, make sure it's pulled in somehow for non-meta users still too)
+# 9. xdg-desktop-portal-gtk for various integration, e.g. #764632
+# 10. TODO: semi-optional webkit-gtk[introspection] for captive portal helper
+RDEPEND="${DEPEND}
+ >=sys-apps/accountsservice-0.6.14[introspection]
+ app-accessibility/at-spi2-core:2[introspection]
+ app-misc/geoclue[introspection]
+ media-libs/graphene[introspection]
+ x11-libs/pango[introspection]
+ net-libs/libsoup:3.0[introspection]
+ >=sys-power/upower-0.99:=[introspection]
+ gnome-base/librsvg:2[introspection]
+
+ >=gnome-base/gnome-session-2.91.91
+ >=gnome-base/gnome-settings-daemon-3.8.3
+
+ x11-misc/xdg-utils
+
+ >=x11-themes/adwaita-icon-theme-3.26
+
+ networkmanager? (
+ net-misc/mobile-broadband-provider-info
+ sys-libs/timezone-data
+ )
+ ibus? ( >=app-i18n/ibus-1.5.26[gtk3,gtk4,introspection] )
+ media-fonts/cantarell
+
+ sys-apps/xdg-desktop-portal-gnome
+"
+# avoid circular dependency, see bug #546134
+PDEPEND="
+ >=gnome-base/gdm-3.5[introspection(+)]
+ >=gnome-base/gnome-control-center-3.26[networkmanager(+)?]
+"
+BDEPEND="
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.45.3
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.17
+ app-text/docbook-xml-dtd:4.5 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( x11-wm/mutter[test] )
+"
+# These are not needed from tarballs, unless stylesheets or manpage get patched with patchset:
+# dev-lang/sassc
+# app-text/asciidoc
+
+PATCHES=(
+ # Change favorites defaults, bug #479918
+ "${FILESDIR}"/40.0-defaults.patch
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Hack in correct python shebang
+ sed -e "s:python\.full_path():'/usr/bin/env ${EPYTHON}':" -i src/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dextensions_tool=true
+ -Dextensions_app=true
+ $(meson_use gtk-doc gtk_doc)
+ -Dman=true
+ $(meson_use test tests)
+ $(meson_use networkmanager)
+ $(meson_use systemd) # this controls journald integration and desktop file user services related property only as of 3.34.4
+ # (structured logging and having gnome-shell launched apps use its own identifier instead of gnome-session)
+ # suspend support is runtime optional via /run/systemd/seats presence and org.freedesktop.login1.Manager dbus interface; elogind should provide what's necessary
+ -Dsoup2=false
+ )
+ meson_src_configure
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if ! has_version "media-libs/mesa[llvm]"; then
+ elog "llvmpipe is used as fallback when no 3D acceleration"
+ elog "is available. You will need to enable llvm USE for"
+ elog "media-libs/mesa if you do not have hardware 3D setup."
+ fi
+
+ optfeature "Bluetooth integration" gnome-base/gnome-control-center[bluetooth] net-wireless/gnome-bluetooth:3[introspection]
+ optfeature "Browser extension integration" gnome-extra/gnome-browser-connector
+ optfeature "Screencast/capture support" media-video/pipewire media-libs/gstreamer[introspection] media-libs/gst-plugins-base[introspection] media-libs/gst-plugins-good media-plugins/gst-plugins-vpx
+ optfeature "Weather support" dev-libs/libgweather:4[introspection]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}